Bug #43672

Admin panel unnecessarily reloads page upon expand/collapse

Added by Stefan Neufeind almost 7 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Start date:
2012-12-06
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

When expanding/collapsing a section in the admin panel it (unnecessarily?) reloads the page.

(Tested on 6.0, but I guess that's standard-behaviour since long.)


Related issues

Related to TYPO3 Core - Epic #84044: Admin Panel Rework Closed 2010-08-11
Related to TYPO3 Core - Feature #22564: The selected preview group in FE is not active if the admin-panel is not expanded. Closed 2010-08-11
Related to TYPO3 Core - Bug #84198: simulate usergroup in admin panel is reset on update Closed 2018-03-11
Related to TYPO3 Core - Feature #84584: Re-Design the admin panel Closed 2018-04-03

History

#1 Updated by Mathias Schreiber over 4 years ago

  • Status changed from New to Accepted
  • Target version set to 7.2 (Frontend)
  • Is Regression set to No

I'm pretty sure this is due to the fact that the AP needs to set parameters on opening/closing

#2 Updated by Stefan Neufeind over 4 years ago

Parameters that get saved you mean? Could we do that via AJAX then?

#3 Updated by Helmut Hummel over 4 years ago

Stefan Neufeind wrote:

Parameters that get saved you mean? Could we do that via AJAX then?

It sets get parameters. Changing that, will mean re-writing the admin panel (internals) as a whole.

#4 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)

#5 Updated by Susanne Moog about 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#6 Updated by Benni Mack almost 4 years ago

  • Target version changed from 7.5 to 7 LTS

#7 Updated by Benni Mack almost 4 years ago

  • Target version changed from 7 LTS to 8 LTS

The rewrite of admin panel did not make it into cms7, so I move it to v8.

#8 Updated by Benni Mack over 2 years ago

  • Target version changed from 8 LTS to Candidate for Major Version

#9 Updated by Riccardo De Contardi over 1 year ago

#10 Updated by Riccardo De Contardi over 1 year ago

  • Related to Feature #22564: The selected preview group in FE is not active if the admin-panel is not expanded. added

#11 Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #84198: simulate usergroup in admin panel is reset on update added

#12 Updated by Riccardo De Contardi over 1 year ago

I took a look with 7.6.23, 8.7.10 and 9.2.0-dev (latest master)

- on all versions expanding/collapsing a single section of admin panel triggers the reloading of the page
- only on version 7.6.23 expanding/collapsing the whole admin panel triggers the reloading of the page

#13 Updated by Susanne Moog about 1 year ago

#14 Updated by Susanne Moog about 1 year ago

  • Category set to AdminPanel

#15 Updated by Susanne Moog about 1 year ago

  • Target version changed from Candidate for Major Version to 9 LTS

#16 Updated by Riccardo De Contardi about 1 year ago

Updated situation after Admin Panel rework:

1) Enabling/Disabling the admin panel (red/green switch icon): forces reload of page
2) Expanding/Collapsing the TypoScript Section: does not force reload of the page
2.1) Expanding/Collapsing the "settigns group": does not force reload of the page
2.2) Clicking on "Save" button forces reload of the page
3) Expanding/Collapsing the Info Section (and all tabs): does not force reload of the page
4) Expanding/Collapsing the Settings Section: does not force reload of the page
4.1) Clicking on "Update settings" button forces reload of the page
4.2) Clicking on "Clear cache of current page" button forces reload of the page
4.3) Clicking on "Clear Frontend cache" button forces reload of the page
4.4) All icons in "Edit" section force a reload of the page (in fact, they open a different page inside /typo3/), except "Open TYPO3 backend" that opens the backend in anoter tab

#17 Updated by Susanne Moog about 1 year ago

  • Status changed from Accepted to Needs Feedback

@Riccardo

If I got this right, the adminpanel only reloads when it needs to now (for example because information changed because of changed settings).

#18 Updated by Stefan Neufeind about 1 year ago

I can't yet provide feedback regarding the redesigned Admin-Panel for 9 LTS. But in previous versions even closing an information-div leaded to a reload, which could of course have happened by just setting a CSS-class to "closed" or something. That was the intention to improve with this issue.

#19 Updated by Susanne Moog about 1 year ago

  • Target version changed from 9 LTS to Candidate for patchlevel

#20 Updated by Susanne Moog 12 months ago

  • Status changed from Needs Feedback to Closed

Fixed with the rewrite.

#21 Updated by Susanne Moog 11 months ago

  • Sprint Focus set to On Location Sprint

Also available in: Atom PDF