Project

General

Profile

Actions

Feature #22564

closed

Epic #84044: Admin Panel Rework

The selected preview group in FE is not active if the admin-panel is not expanded.

Added by Björn Pedersen almost 14 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Target version:
Start date:
2010-08-11
Due date:
% Done:

0%

Estimated time:
PHP Version:
5.2
Tags:
Complexity:
Sprint Focus:

Description

Previewing of group-limited content only works if the admin panel is expanded.

(issue imported from #M15418)


Related issues 3 (0 open3 closed)

Related to TYPO3 Core - Bug #43672: Admin panel unnecessarily reloads page upon expand/collapseClosed2012-12-06

Actions
Related to TYPO3 Core - Bug #84198: simulate usergroup in admin panel is reset on updateClosedFrank Nägler2018-03-11

Actions
Related to TYPO3 Core - Feature #84584: Re-Design the admin panelClosedSusanne Moog2018-04-03

Actions
Actions #1

Updated by Alexander Opitz about 11 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

Actions #2

Updated by Björn Pedersen about 11 years ago

Yes, this behaviour is still there with a TYPO3 4.6 installation.

Actions #3

Updated by Alexander Opitz about 11 years ago

As 4.6 isn't supported any more, I asked if this issue exist in 4.5 or 6.1?

Actions #4

Updated by Christian Buelter about 11 years ago

This issue is still there in 6.1.1

Actions #5

Updated by Alexander Opitz about 11 years ago

  • Status changed from Needs Feedback to New
Actions #6

Updated by Mathias Schreiber over 9 years ago

  • Category set to Frontend
  • Target version set to 7.2 (Frontend)
  • Is Regression set to No
Actions #7

Updated by Benni Mack about 9 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)
Actions #8

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #9

Updated by Benni Mack almost 9 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #10

Updated by Mathias Schreiber over 8 years ago

  • Tracker changed from Bug to Feature
Actions #11

Updated by Riccardo De Contardi over 6 years ago

I performed the following test with 7.6.23, 8.7.10 and 9.2.0-dev (latest master)

Prerequisites

1) BE admin user > enable admin panel using admPanel=1 in his/her TSConfig field
2) FE usergroup "test group"
3) TypoScript Setup:

config.admPanel=1

Test

1) create a page
2) create a content element (e.g. Text With Images) ,write in a lot of text, in Access Tab set its "Usergroup Access Rights" as "test group"
3) Save and preview the page
4) Expand the admin panel, expand the preview section and set "Simulate user group" to "test group" and click "Update"
5) close the whole admin panel

Results with 7.6.23

- on execution of step 4) the page is reloaded and the content becomes visible
- on execution of step 5) the content is hidden again and the page gets reloaded

Verdict: The issue is still present

Results with 8.7.10

- on execution of step 4) the page is reloaded and the content becomes visible
- on execution of step 5) the content remains visible and no reload occurs

Verdict: the issue is solved

NOTE

The issue is present again when you expand/collapse the single "Preview" section of admin panel, this reloads the page.

Results with 9.2.0

- on execution of step 4) the page is reloaded but the content remains invisible, because the "Simulate user group" dropdown is reset. This is a different issue (#84198).

Verdict: on hold because of the issue

Actions #12

Updated by Riccardo De Contardi over 6 years ago

  • Related to Bug #43672: Admin panel unnecessarily reloads page upon expand/collapse added
Actions #13

Updated by Riccardo De Contardi over 6 years ago

  • Related to Bug #84198: simulate usergroup in admin panel is reset on update added
Actions #14

Updated by Susanne Moog over 6 years ago

  • Parent task set to #84044
Actions #15

Updated by Susanne Moog almost 6 years ago

Actions #16

Updated by Susanne Moog almost 6 years ago

  • Category changed from Frontend to AdminPanel
Actions #17

Updated by Susanne Moog almost 6 years ago

  • Status changed from New to Closed

Fixed in 8.7 and Riccardos mentioned issue in 9 was solved in the according ticket.

Actions

Also available in: Atom PDF