Feature #84532

Epic #84776: Initiative GDPR

Allow HTML inside the form element "static text"

Added by SICOR KDL GmbH over 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-03-26
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Hello there,

It should be made possible to add a page link within the "Static Text" Element.

Example for a GDPR/DSGVO compliant form: https://www.e-recht24.de/kontakt.html

Line: "Detaillierte Informationen zum Umgang mit Nutzerdaten finden Sie in unserer Datenschutzerklärung".
=> "Datenschutzerklärung" is required to be a link.


Files

datenschutz.png (6.49 KB) datenschutz.png Julian Stock, 2019-09-19 00:49

Related issues

Is duplicate of TYPO3 Core - Feature #84849: Allow links and some HTML tags in label, description, static text, validators, and emailBodyUnder ReviewRalf Zimmermann2018-04-24

Actions
#1

Updated by Georg Ringer over 2 years ago

  • Subject changed from Form Change for DSGVO compliance required. to Form Change for GDPR/DSGVO compliance required.
  • Description updated (diff)
#2

Updated by Bjoern Jacob over 2 years ago

For now, one can use this small extension to achieve the desired output: https://github.com/tritum/form_element_linked_checkbox

We can discuss if such a form element should be shipped with the core.

#3

Updated by Georg Ringer over 2 years ago

  • Subject changed from Form Change for GDPR/DSGVO compliance required. to Allow HTML inside the form element "static text"
#4

Updated by Georg Ringer over 2 years ago

  • Parent task set to #84776
#5

Updated by Riccardo De Contardi about 2 years ago

I think that these feature requests are somehow related as they suggest alternative solutions for this same problem:

https://forge.typo3.org/issues/84849

https://forge.typo3.org/issues/85137

#6

Updated by Bjoern Jacob about 2 years ago

  • Is duplicate of Feature #84849: Allow links and some HTML tags in label, description, static text, validators, and emailBody added
#7

Updated by Bjoern Jacob about 2 years ago

  • Status changed from New to Closed

Let's continue working on #84849. We have a POC and know what to do but cannot achieve it for v9. This should come with v10.

#8

Updated by Julian Stock about 1 year ago

As a workaround, I wrote the form config in a yaml file

        label: 'Ich habe die <a href="/datenschutz/" target="_blank">Datenschutzbestimmungen</a> gelesen und akzeptiert.'

and used my own Checkbox.html partial of the form extension with the following addition:

<f:format.raw>{formvh:translateElementProperty(element: element, property: 'label')}</f:format.raw>

Also available in: Atom PDF