Bug #84692

Linkhandler configuration in condition results in no links in frontend

Added by Marc Bastian Heinrichs over 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-04-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Scenario:
  • Multi tree instance with different TSconfigs per tree, also for the linkhandler
Expected:
  • link to the record is generated
Problem:
  • no (!) link is generated

Reason:
DatabaseRecordLinkBuilder::build misses $pageTsConfig['TCEMAIN.']['linkHandler.']['identifier']

The former linkhandler extensions uses as link identifier the format "identifier:table_name:uid".
So the TSconfig was not needed in frontend to know the table name.

This was changed in the core implementation to "t3://record?identifier=identifier&uid=uid".
Thus the page TSconfig needs to be fetched and parsed in frontend.
This done by using TypoScriptFrontendController::getPagesTSconfig() which sadly uses TypoScriptParser::parse without proving an ConditionMatcher.

So the additional TSconfig inside a PIDinRootline condition is totally missing.

Fixes:

Solution A:
double the table configuration from TCEMAIN.linkHandler.fooBar.configuration.table to config.recordLinks.fooBar.table
=> additional pro: no TSconfig parsing in FE

Solution B:
call getPagesTSconfig with new optional argument $matchConditions = true, which results in calling parse providing a ConditionMatcher instance.


Files


Related issues

Related to TYPO3 Core - Feature #89718: Unified PageTS resolving and parsingClosedBenni Mack2019-11-21

Actions
#1

Updated by Marc Bastian Heinrichs over 2 years ago

  • File 84692_b.patch added

A patch for B

#3

Updated by Markus Klein over 2 years ago

I'm for Solution B.

Keep the config central at one place.

#4

Updated by Marc Bastian Heinrichs over 2 years ago

  • File deleted (84692_b.patch)
#6

Updated by Julian Stock about 2 years ago

Marc Bastian Heinrichs wrote:

Updated B

any updates on this?

#7

Updated by Julian Stock about 2 years ago

As a workaround, we solved it like this in tsconfig: (Set a default and remove it where the condition is accepted, so you don't have the tab on other rootlines :))

TCEMAIN.linkHandler.tx_news {
    handler = TYPO3\CMS\Recordlist\LinkHandler\RecordLinkHandler
    label = Your label
    configuration {
        table = tx_news_domain_model_news
        storagePid = 1337
        hidePageTree = 1
    }

    scanBefore = page
}

[Vendor\Package\TypoScriptCondition\YourCondition]
    TCEMAIN.linkHandler.tx_news >
[END]
#8

Updated by Susanne Moog about 2 years ago

  • Sprint Focus set to On Location Sprint
#9

Updated by Susanne Moog 11 months ago

  • Sprint Focus deleted (On Location Sprint)
#10

Updated by Markus Klein 11 months ago

  • Status changed from New to Needs Feedback

If I'm not mistaken this is resolved with https://review.typo3.org/c/Packages/TYPO3.CMS/+/62349 for v10

#11

Updated by Georg Ringer 8 months ago

  • Status changed from Needs Feedback to Closed

closed because works now in 10 with #89718

please get in contact me if still not working for you.

#12

Updated by Georg Ringer 8 months ago

  • Related to Feature #89718: Unified PageTS resolving and parsing added

Also available in: Atom PDF