Project

General

Profile

Actions

Bug #86153

closed

FileList fails with SiteNotFoundException

Added by Alexander Jahn almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2018-09-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 9.4 opening the FileList module fails with a SiteNotFound exception.

SiteResolver expects the parameter 'id' to be a pageID that can be resolved to a site configuration.
The FileList module uses the same parameter for a directory.

The parameter is cast to int resulting in TYPO3 trying to resolve a directory identifier as a page id.


Files

Selection_115.jpg (202 KB) Selection_115.jpg Alexander Jahn, 2018-09-05 13:16

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #99121: Have site request attribute in filelist moduleClosed2022-11-17

Actions
Actions #1

Updated by Susanne Moog almost 6 years ago

  • Category set to Link Handling, Site Handling & Routing
Actions #2

Updated by Susanne Moog almost 6 years ago

  • Target version changed from 9.4 to 9 LTS
Actions #3

Updated by Anja Leichsenring almost 6 years ago

  • Status changed from New to Needs Feedback

can not reproduce. Can you elaborate on your setup?

e.g. site configuration yes / no?

Actions #4

Updated by Andreas Kienast almost 6 years ago

I also fail to reproduce the issue. I have a mixed state of regular sites and pseudo sites.

Actions #5

Updated by Alexander Jahn almost 6 years ago

I'm having this problem in a very simple setup.
One rootpage with 5 subpages and a single site configuration.

There are two file storages, (1) is the default fileadmin one, (3) the custom storage throwing the error.

When browsing the filelist for Storage (1) the id parameter '1:/SomeFolder/' is cast to int 1 and can resolve a siteconfiguration for pageID 1.

When browsing the filelist for Storage (3) the id parameter '3:/SomeOtherFolder/' is cast to int 3 and causes an exception because there is no page with uid 3 in my setup.

Actions #6

Updated by Helmut Hummel almost 6 years ago

  • Status changed from Needs Feedback to Accepted

I can confirm the issue. Once the file list is called with an id get parameter, which does not match a valid page the exception is thrown

To reproduce:

  • add a new file storage record
  • delete the page that has the id of the storage record
  • go to file list and try to access the storage
Actions #7

Updated by Anja Leichsenring almost 6 years ago

  • Status changed from Accepted to In Progress
  • Assignee set to Anja Leichsenring
Actions #8

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58337

Actions #9

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58337

Actions #10

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58337

Actions #11

Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58337

Actions #12

Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58337

Actions #13

Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58337

Actions #14

Updated by Anja Leichsenring almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #15

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions #16

Updated by Christian Kuhn over 1 year ago

  • Related to Task #99121: Have site request attribute in filelist module added
Actions

Also available in: Atom PDF