Bug #86244

Font Awesome icons not displayed in safari

Added by Marco Pfeiffer about 2 years ago. Updated 8 months ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-09-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:
Needs Decision

Description

All font awesome icons seem to not work in safari.

Tested in:
Release 65 (Safari 12.1, WebKit 13607.1.5.2)
and Version 11.1.2 (13605.3.8)


Files

#1

Updated by Daniel Goerz almost 2 years ago

  • Description updated (diff)
#2

Updated by Tanel Põld almost 2 years ago

Having the very same issue.
Besides opening "Files module" folder tree shows up only after second click on the module icon, before that it's just blank.
Safari: 12.0.2 (14606.3.4)

1. After Shift-Reload icons show up, folder tree problem remains.
2. After closing and opening Safari and logging in the icons are gone again.

#3

Updated by Riccardo De Contardi over 1 year ago

It seems a general problem about font loading - also the SourceSansPro font seems not loading

I've been able to re-gain the fontawesome icons with

- open developent tools
- open "network" tab
- click on "ignore cache of resources when loading resources
- reload

but after closing and reopening Safari again, the font was gone again.

Maybe it's the same issue? https://github.com/doanythingfordethklok/safari-cache-bug

#4

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from New to Needs Feedback
#5

Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Needs Feedback to New

Still present (Safari 12.1 (14607.1.40.1.4))

#6

Updated by Riccardo De Contardi 10 months ago

I can still reproduce this issue with Safari 13.0.5 (14608.5.12)

#7

Updated by Georg Ringer 9 months ago

works for me, see screenshot, safari Version 13.0.5 (14608.5.12)

#8

Updated by Alexander Dräger 9 months ago

I still have the error with TYPO3 9.5.13

#9

Updated by Alexander Dräger 9 months ago

@Riccardo De Contardi if I clear the cache like here https://github.com/doanythingfordethklok/safari-cache-bug it works.

#10

Updated by Riccardo De Contardi 9 months ago

Alexander Dräger wrote:

@Riccardo De Contardi if I clear the cache like here https://github.com/doanythingfordethklok/safari-cache-bug it works.

Yes, Alexander, but it is just a palliative: when you quit the browser and open it again the issue will come out again (As I wrote on my comment 3)

#11

Updated by Georg Ringer 8 months ago

  • Sprint Focus set to Needs Decision
#12

Updated by Georg Ringer 8 months ago

  • Status changed from Needs Feedback to Rejected

closed as nothing we can really do about it. please contact me or Riccardo on slack if you got a different opinion

Also available in: Atom PDF