Bug #86277

Editlock blocks edit button also for admin

Added by Guido Schmechel 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Category:
Backend User Interface
Target version:
Start date:
2018-09-16
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

Affected version
9.5-dev

Steps to reproduce:
  • Edit page properties
  • Set editlock to true
  • Save

Now the edit button is hidden because of the editlock property.


Related issues

Related to TYPO3 Core - Task #84375: Use ServerRequestInterface in PageLayoutController Closed 2018-03-16

Associated revisions

Revision f21e9662 (diff)
Added by Guido Schmechel 11 months ago

[BUGFIX] Make edit button visible for admin

If user is logged in as admin, the edit buttons are always displayed.

Resolves: #86277
Releases: master
Change-Id: I80f96df09c2f4fab886e03cf5aa4cb91cb1bf06c
Reviewed-on: https://review.typo3.org/58296
Tested-by: TYPO3com <>
Reviewed-by: Richard Haeser <>
Reviewed-by: Tobi Kretschmann <>
Tested-by: Tobi Kretschmann <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58296

#2 Updated by Susanne Moog 11 months ago

  • Category set to Backend User Interface

#3 Updated by Ben Robinson 11 months ago

I have tested the patch: it adds the "Edit page properties" button, but the "Create new content element button" ist still missing in the page-module (9.4.0).
It is already accessible in the list module and it is possible to move and edit existing elements in the page module with an admin-account.

#4 Updated by Guido Schmechel 11 months ago

Hi Ben, thanks for your comment. I will have a further look at this patch because of more hints from Josef beside the visibillity of buttons.

#5 Updated by Gerrit Code Review 11 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58296

#6 Updated by Mathias Brodala 11 months ago

  • Related to Task #84375: Use ServerRequestInterface in PageLayoutController added

#7 Updated by Mathias Brodala 11 months ago

  • Is Regression set to Yes

This was a regression introduced with #84375.

#8 Updated by Guido Schmechel 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF