Bug #86397

Link across domains not possible

Added by David Bruchmann about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Link Handling, Site Handling & Routing
Start date:
2018-09-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In former versions links across domains got the domain adjusted.
This never seems being the case anymore.
Playing with the parameters `config.typolinkEnableLinksAcrossDomains` and `config.typolinkCheckRootline` never has any remarkable impact.
No matter if no, any of both or both parameters together are set, the target page never gets the domain adjusted and the Error "ID was outside the domain" is shown.

History

#1 Updated by Markus Klein about 1 year ago

  • Description updated (diff)
  • Assignee set to Benni Mack

#2 Updated by Benni Mack about 1 year ago

  • Target version changed from next-patchlevel to 9 LTS

#3 Updated by Benni Mack about 1 year ago

Hi David,

I take the following assumption:

1. you're using RealURL in TYPO3 v9, right?
2. you're not having any site configuration running, right=

For your clarification,

1. config.typolinkEnableLinksAcrossDomains was only introduced for RealURL, so you need to have that.

2. config.typolinkCheckRootline is always on by default, so this is not necessary anymore - see https://docs.typo3.org/typo3cms/extensions/core/latest/Changelog/9.0/Deprecation-82909-TypoScriptOptionConfigtypolinkCheckRootline.html

#4 Updated by Benni Mack about 1 year ago

  • Status changed from New to Needs Feedback
  • Target version changed from 9 LTS to Candidate for patchlevel

#5 Updated by David Bruchmann about 1 year ago

Hi Benni,

no, I don't have realurl installed, especially as there won't be a version for TYPO3 9 probably.

The parameters I tried after having problems to get the pages linked correct, though anything without success till now.

#6 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to New

#7 Updated by David Bruchmann about 1 year ago

  • % Done changed from 0 to 100

With site-configuration and proper slugs everything is working fine now.
Issue can be closed.

#8 Updated by Wouter Wolters about 1 year ago

  • Status changed from New to Closed

#9 Updated by Thomas Goetz about 1 year ago

So it's mandatory to create the Site configuration for this to work?
I have the same error, links to another page tree led to an exception. After I created the Site configuration, it works fine.

Shouldn't it work without this configuration when i dont want to use speaking urls?

#10 Updated by Benni Mack about 1 year ago

Hi Thomas,

well, site configuration will be mandatory in v10 (as the sole solution) - because it adds information which TYPO3 had to guess previously. So if you have one pagetree without and the other with site configuration, we might get into trouble. This needs to be checked. With site configuration, this option is turned on anyway, but without site config, the option config.typolinkEnableLinksAcrossDomains will still have a behaviour.

Also available in: Atom PDF