Bug #86722

Not possible to deactivate deprecation-log in typo3temp/var/log/

Added by Wittkiel Gruppe over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Logging
Target version:
-
Start date:
2018-10-23
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

We are using TYPO3 9.5.0 (no composer) in production/live-mode with some well-known extensions like DCE, Gridelements and Powermail. Most extensions are developed for multiple versions for example 8.7 - 9.5, so they often use some deprecated things which are all logged in /typo3temp/var/log/typo3_deprecations_xxx.log. With TYPO3 9.5.0 it seems not possible anymore to deactivate this deprecation-log (see #82438, $GLOBALS['TYPO3_CONF_VARS']['SYS']['enableDeprecationLog'] has no effect anymore), which will grow with each hit and can influence the performance. In production/live-mode this log is unnecessary.


Related issues

Related to TYPO3 Core - Bug #89769: Configuration preset "Live" does not disable deprecations logs Accepted 2019-11-25

History

#1 Updated by Markus Klein over 1 year ago

  • Status changed from New to Rejected

Not a bug, but a changed behavior.

Deprecations now use the normal logging API so it can all be controlled the usual way.

See also: https://docs.typo3.org/typo3cms/extensions/core/latest/Changelog/9.0/Deprecation-82438-DeprecationMethods.html

How to configure logging can be found in: https://docs.typo3.org/typo3cms/CoreApiReference/ApiOverview/Logging/Configuration/Index.html#writer-configuration

The scope used by the Core is "TYPO3.CMS.deprecations".

The default configuration is:

    'LOG' => [
        'writerConfiguration' => [
            \TYPO3\CMS\Core\Log\LogLevel::WARNING => [
                \TYPO3\CMS\Core\Log\Writer\FileWriter::class => []
            ]
        ],
        'TYPO3' => [
            'CMS' => [
                'deprecations' => [
                    'writerConfiguration' => [
                        \TYPO3\CMS\Core\Log\LogLevel::NOTICE => [
                            \TYPO3\CMS\Core\Log\Writer\FileWriter::class => [
                                'logFileInfix' => 'deprecations'
                            ],
                        ]
                    ]
                ]
            ]
        ],
    ],

#2 Updated by Wittkiel Gruppe over 1 year ago

Markus Klein wrote:

Not a bug, but a changed behavior.

Deprecations now use the normal logging API so it can all be controlled the usual way.

Thanks for the hints! With this line in myext/ext_localconf.php i have disabled the deprecation-log:

$GLOBALS['TYPO3_CONF_VARS']['LOG']['TYPO3']['CMS']['deprecations']['writerConfiguration'][\TYPO3\CMS\Core\Log\LogLevel::NOTICE] = array();

#3 Updated by Markus Klein 2 months ago

  • Related to Bug #89769: Configuration preset "Live" does not disable deprecations logs added

Also available in: Atom PDF