Bug #86821

Slug generator doesn't work for custom records anymore in 9.5.1

Added by Jacco van der Post almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-11-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have in my domain model

        'slug' => [
            'label' => 'LLL:EXT:core/Resources/Private/Language/locallang_tca.xlf:pages.slug',
            'exclude' => 1,
            'config' => [
                'type' => 'slug',
                'generatorOptions' => [
                    'fields' => ['subject'],
                    'fieldSeparator' => '/',
                    'prefixParentPageSlug' => false,
                ],
                'fallbackCharacter' => '-',
                'eval' => 'uniqueInSite',
            ],
        ],

When creating a record in 9.5.0 backend the slug field gets auto filled. Also the 'Recalculate URL segment from page title' refresh button does not work anymore to (re)generate the segment.

In 9.5.1 it does not work.

Another question (of topic sry) how can I generate a slug in a domain model of controller for example during a createAction?


Files

typo3_8aacc053fe.log (16.5 KB) typo3_8aacc053fe.log Exception stack trace for SlugHelper::buildSlugForUniqueInPid() Chris Müller, 2018-11-05 10:37

Related issues

Related to TYPO3 Core - Bug #86849: Slug generation in record fails since update to 9.5.1Rejected2018-11-05

Actions
Is duplicate of TYPO3 Core - Bug #86809: Resolve strict type assertion in RecordStateFactoryClosed2018-10-31

Actions

Also available in: Atom PDF