Bug #86849

Slug generation in record fails since update to 9.5.1

Added by Chris Müller almost 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-11-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given is a record in an own extension with a slug field.

The TCA configuration is as follows:

'path_segment' => [
'label' => 'Path segment',
'exclude' => true,
'config' => [
'type' => 'slug',
'generatorOptions' => [
'fields' => ['title'],
'fieldSeparator' => '/',
'prefixParentPageSlug' => false,
],
'fallbackCharacter' => '-',
'eval' => 'uniqueInPid',
],
],

Clicking on the button for recalculating the slug throws an exception (see attachment).

The same exception occurs when saving the record. So it's not possible anymore to save a record!

I am using a multi-lingual single-page tree (I don't know if this is relevant).

I can reproduce the error in the news extension.

It seems to me that this is a regression related to the fix for bug #86195.


Files

typo3_8aacc053fe.log (14.9 KB) typo3_8aacc053fe.log Exception Stack Trace Chris Müller, 2018-11-05 09:53

Related issues

Related to TYPO3 Core - Bug #86821: Slug generator doesn't work for custom records anymore in 9.5.1Closed2018-11-01

Actions
Related to TYPO3 Core - Bug #86809: Resolve strict type assertion in RecordStateFactoryClosed2018-10-31

Actions

Also available in: Atom PDF