Bug #87227

[FE][disableNoCacheParameter] disables TypoScript no_cache, too

Added by bitfire it services about 1 year ago. Updated 3 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2018-12-19
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Steps to reproduce:

1. Set [FE][disableNoCacheParameter] = true (because I don't want no_cache request parameters to cause server load)
2. Use TypoScript for root page: config.no_cache = 1 (for development)

Result:

Pages will still be cached. I have to clear the cache for every template change etc.

Expected result:

Pages are not cached, because according to the description of [FE][disableNoCacheParameter], the setting only controls "the no_cache request parameter".


Related issues

Related to TYPO3 Core - Bug #79582: [FE][disableNoCacheParameter] does not work correctly / forces caching Closed 2017-02-01

Associated revisions

Revision b37441e8 (diff)
Added by Benni Mack 3 days ago

[BUGFIX] disableNoCacheParameter option allows TypoScript cache option

With this change applied, a TYPO3 installation having the
global "disableNoCacheParameter" option activated will
still disable the cache if set via TypoScript `config.no_cache = 1`.

However, the GET parameter is still not evaluated when
having the option activated.

Resolves: #87227
Releases: master, 9.5
Change-Id: Id33bd3aa9c8d042deffadeb19d8d64d52fad3371
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62835
Reviewed-by: Daniel Goerz <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Tobi Kretschmann <>
Tested-by: Susanne Moog <>
Tested-by: TYPO3com <>
Tested-by: Tobi Kretschmann <>

Revision 5e7759d3 (diff)
Added by Benni Mack 3 days ago

[BUGFIX] disableNoCacheParameter option allows TypoScript cache option

With this change applied, a TYPO3 installation having the
global "disableNoCacheParameter" option activated will
still disable the cache if set via TypoScript `config.no_cache = 1`.

However, the GET parameter is still not evaluated when
having the option activated.

Resolves: #87227
Releases: master, 9.5
Change-Id: Id33bd3aa9c8d042deffadeb19d8d64d52fad3371
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62905
Tested-by: TYPO3com <>
Tested-by: Tobi Kretschmann <>
Reviewed-by: Tobi Kretschmann <>

History

#1 Updated by Georg Ringer about 1 year ago

  • TYPO3 Version changed from 9 to 8

can confirm and is also valid for 8

#2 Updated by Mathias Bolt Lesniak 3 months ago

For what it's worth: This issue is causing blank pages in EXT:frontend_editing

#3 Updated by Gerrit Code Review 9 days ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62835

#4 Updated by Benni Mack 5 days ago

  • Related to Bug #79582: [FE][disableNoCacheParameter] does not work correctly / forces caching added

#5 Updated by Gerrit Code Review 4 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62835

#6 Updated by Gerrit Code Review 3 days ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62905

#7 Updated by Benni Mack 3 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF