Bug #87453

Contextmenu with left click can only be triggered via exact hover on a svg path

Added by Josef Glatz almost 3 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2019-01-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Problem/Description

It is possible to trigger the contextmenu of a pagetree item via the click on the icon of the element with a left mouse click. Since the rewrite of the pagetree, this feature feels buggy. This is only because of the fact, that the tooltip and the contextmenu via left click does only work if the cursor is exactly above a svg path/element of the inline placed icon.


Related issues

Related to TYPO3 Core - Bug #93284: Context-menu in pagetree does not open for page-type "external link" with the "chain"-icon - only the non-transparent part of a SVG-icon in Pagetree is clickableClosed2021-01-13

Actions

Also available in: Atom PDF