Bug #87958

TranslateViewHelper error in AbstractViewHelper

Added by Harald Holzmann 10 months ago. Updated 6 days ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-03-20
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Hello,

every time I try to login to Typo3 Backend, I receive the following error message " Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1256475113: The argument "arguments" was registered with type "array", but is of type "string" in view helper "TYPO3\CMS\Fluid\ViewHelpers\TranslateViewHelper". | InvalidArgumentException thrown in file /var/www/html/vendor/typo3fluid/fluid/src/Core/ViewHelper/AbstractViewHelper.php in line 365."

I looked up where it is used and found that it is used in the File "UserToolbarItemDropDown.html" in line 36. When i cahnge the line from
<a href="{user.switchUserLink}" title="{f:translate(key: 'usermodule.su.tooltip', arguments: {0: user.username})}">
to
<a href="{user.switchUserLink}" title="{f:translate(key: 'usermodule.su.tooltip', arguments: '{0: user.username}')}">

everything is okay. I think there is the call of the translate view helper broken.

Kind regards,
Harald


Related issues

Related to TYPO3 Core - Bug #87573: TYPO3 CMS Exception 1256475113 in Extension Manager Needs Feedback 2019-01-29
Related to TYPO3 Core - Bug #88415: InvalidArgumentException in SiteConfiguration Closed 2019-05-22

History

#1 Updated by Josef Glatz 10 months ago

  • Description updated (diff)

#2 Updated by Rene Tobias Tobias 10 months ago

Hey, i can confirm this error to on 7.3

#3 Updated by Clemens Riccabona 10 months ago

I have this every now and then now in several installations when entering the Extension Manager on TYPO3 v8 (8.7.24)
Starts to be anoying ... ;)

#4 Updated by Harald Holzmann 10 months ago

Clemens Riccabona wrote:

I have this every now and then now in several installations when entering the Extension Manager on TYPO3 v8 (8.7.24)
Starts to be anoying ... ;)

I think this issue is not related to php version or setup/config, not to typo3 version. Which php Version do you use?

#5 Updated by Clemens Riccabona 10 months ago

I use 7.2.X as well as 7.3.x

it occurs occasionally on both.

See also: #87573

EDIT: nope, it does not occur on php 7.2, as far as i can see.
Sorry, I mixed that up due to different server configurations and local machine ...
[I have server with 7.3 and 7.2 ... locally 7.3]

#6 Updated by Riccardo De Contardi 10 months ago

  • Related to Bug #87573: TYPO3 CMS Exception 1256475113 in Extension Manager added

#7 Updated by Denny Lubitz 9 months ago

I can also confirm this issue.

OS: FreeBSD 11.2-RELEASE-p9 amd64
PHP: 7.3.4

#9 Updated by Susanne Moog 6 months ago

  • Related to Bug #88415: InvalidArgumentException in SiteConfiguration added

#10 Updated by Benni Mack 6 days ago

  • Status changed from New to Closed

Hey all,

we've fixed this in TYPO3 v9.5.13 in all TYPO3 Core templates, hope this helps. If you need further assistance, feel free to reach out to me, and I will re-open the ticket.

Benni.

Also available in: Atom PDF