Bug #87573

TYPO3 CMS Exception 1256475113 in Extension Manager

Added by Robert von Hackwitz almost 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Start date:
2019-01-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Fresh TYPO3 install with:
Centos 7
Mysql 5.7
Php 7.3
Apache 2.4.6

Using Extension Manager -> "Get Extensions" cause:
Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1256475113: The argument "arguments" was registered with type "array", but is of type "integer" in view helper "TYPO3\CMS\Fluid\ViewHelpers\Widget\UriViewHelper". | InvalidArgumentException thrown in file /PATH/TO/TYPO3/vendor/typo3fluid/fluid/src/Core/ViewHelper/AbstractViewHelper.php in line 356

Using Php 7.2: everything works fine


Files


Related issues

Related to TYPO3 Core - Bug #87958: TranslateViewHelper error in AbstractViewHelperClosed2019-03-20

Actions
Related to TYPO3 Core - Bug #88415: InvalidArgumentException in SiteConfigurationClosed2019-05-22

Actions
Related to TYPO3 Core - Bug #87970: Sites configuration module brokenClosedFrank Naegler2019-03-20

Actions
Related to Backend User Administration - Bug #90253: Backend User Module listing :: TYPO3 CMS ExceptionNew2020-01-30

Actions
#1

Updated by Georg Ringer almost 2 years ago

  • Status changed from New to Needs Feedback

thanks for creating the issue!
I can't reproduce it, can you check which template part cause the issue on your system?

#2

Updated by Robert von Hackwitz almost 2 years ago

Georg Ringer wrote:

thanks for creating the issue!
I can't reproduce it, can you check which template part cause the issue on your system?

Hi, it isn't a template issue but an Extension Manager issue.
Occasionally occurs when you choose "Get Extensions" on dropdown menu in Extension Manager

#3

Updated by Ion Mirzenco almost 2 years ago

I have the same error using "Add new configuration for this site" and with Reports module

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1256475113: The argument "arguments" was registered with type "array", but is of type "integer" in view helper "TYPO3\CMS\Fluid\ViewHelpers\Widget\UriViewHelper". | InvalidArgumentException thrown in file /PATH/TO/TYPO3/vendor/typo3fluid/fluid/src/Core/ViewHelper/AbstractViewHelper.php in line 356

Operyting System FreeBSD 12
Typo3 version 9.5.4
Php 7.3.2
Nginx 1.14
MariaDB 10.3

Fresh install nothing changed.
Could add the site configuration manually with config.yaml file but reports module doesn't open...

Using Php 7.2: everything works fine

With php 7.2.15 => ok

#4

Updated by Clemens Riccabona over 1 year ago

Is related to #87958

Can confirm this bug with php 7.3

#5

Updated by Clemens Riccabona over 1 year ago

Possible solutions:

EXT:extensionmanager/Resources/Private/

- Templates/List/Index.html

Line 55:

arguments: '{0:extension.updateToVersion.version}'

instead of

arguments: {0:extension.updateToVersion.version}

- Partials/List/UnresolvedDependencies.html

Line 13:

arguments: '{key: key}'

instead of

arguments: {key: key}

#6

Updated by Clemens Riccabona over 1 year ago

Robert von Hackwitz wrote:

Georg Ringer wrote:
Hi, it isn't a template issue but an Extension Manager issue.
Occasionally occurs when you choose "Get Extensions" on dropdown menu in Extension Manager

It is a template issue of the Extension Manager Templates ... ;)

#7

Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #87958: TranslateViewHelper error in AbstractViewHelper added
#8

Updated by Joerg Boesche over 1 year ago

Georg Ringer wrote:

thanks for creating the issue!
I can't reproduce it, can you check which template part cause the issue on your system?

As Georg mentioned, I also can't reproduce the issue on serveral T3 instances and php versions.

#9

Updated by Benni Mack over 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel
#11

Updated by Susanne Moog over 1 year ago

  • Related to Bug #88415: InvalidArgumentException in SiteConfiguration added
#12

Updated by Robert von Hackwitz over 1 year ago

Bug confirmed in another typo3 installation on Linux CentOs 7.6
Environment:
OS: CentOs 7.6
Http Server: httpd-2.4.6-89
Mysql: mysql-community-server-5.7.27-1
Php: php-7.3.8-1 (mod_php NOT php-fpm)

#13

Updated by Jan Greth about 1 year ago

Can also confirm bug:

Operating system: Unix
PHP version: 7.3.8
PHP CGI detected: No
Database connection 'Default'
Version: MySQL 5.5.62

#14

Updated by Bernd Glückert about 1 year ago

Bug confirmed in another typo3 installation on Gentoo Linux

Environment:
OS: Gentoo, Kernel 5.3.2
Http Server: Apache/2.4.41
Database: 10.4.8-MariaDB
Php: PHP 7.3.10

Error message in t3 log:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1256475113: The argument "arguments" was registered with type "array", but is of type "integer" in view helper "TYPO3\CMS\Fluid\ViewHelpers\Widget\UriViewHelper". | InvalidArgumentException thrown in file /var/www/example.com/typo3_src-8.7.12/vendor/typo3fluid/fluid/src/Core/ViewHelper/AbstractViewHelper.php in line 356. Requested URL: https://www.example.com/typo3/index.php?M=tools_ExtensionmanagerExtensionmanager&moduleToken=9cfa1731a7999cd6dd50c24b3c7a6fa58eb254b6&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Baction%5D=ter&tx_extensionmanager_tools_extensionmanagerextensionmanager%5Bcontroller%5D=List

#15

Updated by Jan Greth about 1 year ago

Problem persists also in TYPO3 CMS v9.5.10

#16

Updated by Sebastian Michaelsen about 1 year ago

Pointer: The problem is also discussed here https://github.com/TYPO3/Fluid/issues/449, but without any breakthrough yet.

#17

Updated by Benni Mack 11 months ago

  • Related to Bug #87970: Sites configuration module broken added
#18

Updated by Benni Mack 11 months ago

Hey everybody,

can you please check if the error still exists in TYPO3 v9.5.13? We've fixed this with https://review.typo3.org/c/Packages/TYPO3.CMS/+/62450 in v10 and v9.

Thanks for the pointers.

#19

Updated by Ebin Mathew 10 months ago

  • Related to Bug #90253: Backend User Module listing :: TYPO3 CMS Exception added
#20

Updated by Georg Ringer 9 months ago

  • Status changed from Needs Feedback to Closed

closing because solved + lack of feedback

Also available in: Atom PDF