Bug #88156

It is not possible to mass update a slug field in single table view

Added by Thomas Löffler 4 months ago. Updated 16 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-04-16
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Reproduce:

  1. Generate several pages
  2. Create a state where you need to update all slugs of the pages (e.g. move some pages below another page)
  3. Switch to the parent page and list module
  4. Switch to single table view
  5. Select slug field to show in table
  6. Click the edit button on top of the slug column to only edit the slug fields of all pages
  7. Click on the "update" button
  8. Nothing happens

I think there is some JS missing or maybe an ID problem in this view:

New_TYPO3_site__TYPO3_CMS_9_5_5_.jpg View (239 KB) Thomas Löffler, 2019-04-16 11:10

how-to-get-there.png View (14.6 KB) Georg Ringer, 2019-04-24 12:27

result.png View (20.9 KB) Georg Ringer, 2019-04-24 12:27

Associated revisions

Revision 9a110867 (diff)
Added by Georg Ringer 16 days ago

[BUGFIX] Render slug dependent fields in single table view

If only the slug field should be rendered in the record list, all fields
which are required to generate the slug are added as well.

This makes it possible to have a simple mass update option for slug fields.

Resolves: #88156
Releases: master, 9.5
Change-Id: Ie8463691bc715c92668f65170948ad2518520528
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317
Tested-by: TYPO3com <>
Tested-by: Josef Glatz <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Anja Leichsenring <>

Revision 1489221a (diff)
Added by Georg Ringer 16 days ago

[BUGFIX] Render slug dependent fields in single table view

If only the slug field should be rendered in the record list, all fields
which are required to generate the slug are added as well.

This makes it possible to have a simple mass update option for slug fields.

Resolves: #88156
Releases: master, 9.5
Change-Id: Ie8463691bc715c92668f65170948ad2518520528
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61357
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Anja Leichsenring <>

History

#1 Updated by Georg Ringer 4 months ago

  • Status changed from New to Accepted

#2 Updated by Georg Ringer 4 months ago

Please check out my screenshots. you need to have the title field available as well.

can I close the issue?

#3 Updated by Christian Buelter 4 months ago

Thanks for explaining. The workflow shown in the screenshots works in my case. Before that I also tried to only mass-edit the slug field (without having the title) which does not work.

#4 Updated by Thomas Löffler 3 months ago

Yes, it works with the title field. But most user will run into the same issue than me, because until now you didn't need another field in mass-edit to edit one field.
It should either work without title field or there must be a hint for editors.

#5 Updated by Josef Glatz 3 months ago

It will get more complicated if https://docs.typo3.org/typo3cms/extensions/core/latest/Changelog/9.4/Feature-84729-NewTCATypeSlug.html is configured and needs more fields.

#6 Updated by Gerrit Code Review about 1 month ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317

#7 Updated by Gerrit Code Review 19 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317

#8 Updated by Gerrit Code Review 18 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317

#9 Updated by Gerrit Code Review 18 days ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317

#10 Updated by Gerrit Code Review 18 days ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317

#11 Updated by Gerrit Code Review 16 days ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61317

#12 Updated by Gerrit Code Review 16 days ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61357

#13 Updated by Gerrit Code Review 16 days ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61357

#14 Updated by Georg Ringer 16 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF