Bug #88337

Edit pencil visible in page view when no user has no access

Added by Ruud Silvrants over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2019-05-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The edit pencil to edit the title in the page module is visible while the user has due language restrictions no access to edit this title.

Steps to reproduce:
- Make an editor restricted to only make changes for a certain language.
- In the page module, set the dropdown list to the default language (enlish in my case)
- The user still gets the pencil to edit, but this not aloud.

See screenshot.

Related to https://forge.typo3.org/issues/87971.


Files

edit-inline-page-pencil.png (7.33 KB) edit-inline-page-pencil.png Ruud Silvrants, 2019-05-13 08:34

Related issues

Related to TYPO3 Core - Bug #87971: Edit inline page title from default language possible with language restriction setClosed2019-03-20

Actions
Related to TYPO3 Core - Bug #89627: Respect language restrictions for direct page title editing in list moduleNewDaniel Goerz2019-11-09

Actions
#1

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#2

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#3

Updated by Riccardo De Contardi over 2 years ago

  • Related to Bug #87971: Edit inline page title from default language possible with language restriction set added
#4

Updated by Riccardo De Contardi over 2 years ago

Is this one related? #75130

#5

Updated by Ruud Silvrants over 2 years ago

Riccardo De Contardi wrote:

Is this one related? #75130

The other issue could be resolved in #87971. This issue is that the pencil is still visible due the user can't edit this. From UX point of view the user shouldn't see the pencil anymore, editing itself is already not possible due to #87971.

#6

Updated by Christian Eßl about 2 years ago

  • Category set to Backend API
#7

Updated by Gerrit Code Review about 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#8

Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#9

Updated by Gerrit Code Review almost 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#10

Updated by Gerrit Code Review almost 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#11

Updated by Gerrit Code Review almost 2 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60837

#12

Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62272

#13

Updated by Gianluigi Martino almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Daniel Goerz almost 2 years ago

  • Related to Bug #89627: Respect language restrictions for direct page title editing in list module added
#15

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF