Bug #88365

<style> element in fluid templates breaks output since PHP 7.3.5

Added by Patrick no-lastname-given over 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2019-05-15
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.3
Tags:
php73
Complexity:
Is Regression:
Sprint Focus:

Description

With PHP 7.3.5 the frontend and mail output is broken and a php warning in the backend log is shown, if the <style> element is used in fluid templates or layouts.

I use the <style> element in some plugin fluid templates (ext:powermail), with PHP 7.3.5 the frontend output is broken.

I also use the <style> element in some plugin fluid layouts for mails (ext:powermail), with PHP 7.3.5 the mail output is broken. After each form submit, the following two warnings are shown in the backend log:

Core: Error handler (FE): PHP Warning: Invalid argument supplied for foreach() in /<REMOVED>/vendor/typo3fluid/fluid/src/Core/Parser/TemplateParser.php line 591

Core: Error handler (FE): PHP Warning: Invalid argument supplied for foreach() in /<REMOVED>/vendor/typo3fluid/fluid/src/Core/Parser/TemplateProcessor/NamespaceDetectionTemplateProcessor.php line 180

Temporary fix: Moving styles from the <style> element in the fluid templates to a external file and remove the <style> rules to (only) inline styles in the fluid mail layouts.

I don't think this is a issue of ext:powermail, because this issue: https://github.com/TYPO3/Fluid/issues/452

Also available in: Atom PDF