Bug #88550

EXT:form: It's not possible to set the value for reply-to dynamically

Added by Wolfgang Wagner almost 2 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2019-06-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

In the current TYPO3-Master 10.0.0-dev it is not possible to use the value for reply-to from the form input in a form.

Due to the increasingly stringent spam checks by e-mail providers, it should be possible to read the value for reply-to from the form. It should therefore be possible to use the e-mail address that a user enters in the frontend.

At the moment this does not seem to work, when sending the form an error message appears:

Swift_RfcComplianceException
Address in mailbox given [{email-1}] does not comply with RFC 2822, 3.6.2.

Attached you find a screenshot of my form configuration.


Files

2019-06-13_08-53-32.jpg (76.1 KB) 2019-06-13_08-53-32.jpg Wolfgang Wagner, 2019-06-13 08:58

Related issues

Related to TYPO3 Core - Feature #80420: Allow multiple recipients in EmailFinisherClosedMathias Brodala2017-03-23

Actions
Has duplicate TYPO3 Core - Bug #92781: Placeholders not working in multiple recipient keys/addressesClosedMathias Brodala2020-11-06

Actions

Also available in: Atom PDF