Bug #88812

Info - PageTree Overview - basic settings view displays wrong value for field

Added by Joerg Boesche over 1 year ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
SEO
Target version:
Start date:
2019-07-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The PageTree overview in the info modul displays wrong values for fields. (See attached screenshot)

Extending the fieldDefinitions with "no_index" and "no_follow" of the EXT:seo, the output is "No index: yes" and "No follow: yes", even though the page is enabled for index and follow.
Might be an issue with the new TCA config "invertStateDisplay". The mod.web_info.fieldDefinitions should respect the setting of "invertStateDisplay" to display correct values for the fields.

How to produce the output (no_index,no_follow)

mod.web_info.fieldDefinitions {
 0 {
   label = LLL:EXT:info/Resources/Private/Language/locallang_webinfo.xlf:pages_0
   fields = title,uid,slug,alias,starttime,endtime,fe_group,target,url,shortcut,shortcut_mode,no_index,no_follow
   }             
}


Files

#1

Updated by Georg Ringer over 1 year ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
#2

Updated by Daniel Windloff over 1 year ago

  • Category changed from Backend User Interface to SEO

Seems to be a TCA issue.
Labels on tca column "no_index" and label on robots palette "No index" and "Index this page" are inconsistent.

#3

Updated by Riccardo De Contardi 11 months ago

Still reproducible on 10.3.0-dev.

As far as I can see the "wrong" labels are

typo3/sysext/seo/Resources/Private/Language/locallang_tca.xlf:pages.no_index
typo3/sysext/seo/Resources/Private/Language/locallang_tca.xlf:pages.no_follow

and are just used here: typo3/sysext/seo/Configuration/TCA/Overrides/pages.php lines 79 and 95

I would suggest to use instead:

typo3/sysext/seo/Resources/Private/Language/locallang_tca.xlf:pages.no_index_formlabel
typo3/sysext/seo/Resources/Private/Language/locallang_tca.xlf:pages.no_follow_formlabel

which are the ones used in the palette.

#4

Updated by Gerrit Code Review 9 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63312

#5

Updated by Christian Eßl 9 months ago

The labels were wrong in the "Display information" window of a page as well. (for the same reasons).

#6

Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63295

#7

Updated by Christian Eßl 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack 9 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF