Bug #88832

autocomplete="off" on password fields in install tool configuration settings does not seem to work

Added by Lars Peter S√łndergaard almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2019-07-24
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
CodingNight
Complexity:
Is Regression:
Sprint Focus:

Description

I tried the applied patch in #88709, that sets the attribute autocomplete="off" on most fields, in a TYPO3 9.5.8 installation.

The issue is, I told my Browser (Chrome) to save the TYPO3 login credentials. And afterwards, whenever I go into install Tool Settings and open the popup for "Configure Installation-Wide Options", it automatically fills in the username and passwords in some fields.

In Chrome (75) it has (so far) always been the filter input field (at the top) for the username and the password goes into the "[MAIL][transport_smtp_password]" setting. In Firefox (68) username and password goes into "[MAIL][transport_smtp_username]" and "[MAIL][transport_smtp_password]" resp.
I could not reproduce the issue in Microsoft Edge. Haven't tried other browsers yet.

This problem still occurs with the applied patch, that sets autocomplete="off" on those fields in both browsers.

However it seems for password fields you can use autocomplete="new-password" to avoid the autofilling in those fields. Changing only that for password fields (in .../Partials/Settings/LocalConfiguration/SubSection.html) made it work for both Chrome (75) and Firefox (68) in my installation.

According to the compatibility table on this page the "new-password" it's supported in firefox since version 67.
https://developer.mozilla.org/en-US/docs/Web/HTML/Attributes/autocomplete#Browser_compatibility

As I understand it those values are only hints for the Browser anyway and are not guaranteed to work. Also, those values for the autocomplete attribute seem to be only a recommendation at the moment and have not been officially merged in the HTML5 Standard. So it might change.


Related issues

Related to TYPO3 Core - Bug #88851: Configure Installation wide options -> search field is handled as login fieldClosed2019-07-29

Actions
Related to TYPO3 Core - Bug #88709: mail config input fields in Installation-Wide Options get autocompleted with TYPO3 backend username/passwordClosed2019-07-09

Actions
#1

Updated by Guido Schmechel almost 3 years ago

  • Related to Bug #88851: Configure Installation wide options -> search field is handled as login field added
#2

Updated by Henri Nathanson almost 3 years ago

  • Related to Bug #88709: mail config input fields in Installation-Wide Options get autocompleted with TYPO3 backend username/password added
#3

Updated by Susanne Moog almost 3 years ago

  • Tags set to CodingNight
#4

Updated by Susanne Moog almost 3 years ago

  • Target version set to next-patchlevel
#5

Updated by Andreas Fernandez almost 3 years ago

  • Status changed from New to In Progress

Issue is very likely that "Configure Installation-Wide Options" doesn't use a <form> tag at all.

Update:
Screw that, it looks like Chrome has issues with autocomplete in general again sigh

#6

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61451

#7

Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61459

#8

Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61459

#9

Updated by Andreas Fernandez almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF