Project

General

Profile

Actions

Bug #88873

closed

ext: form hangs (run into 500 error) when a lot of files are in the fileadmin

Added by Christian Hackl almost 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2019-11-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
performance
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 9.5.8 with many many many files in the fileadmin directory.

if you click on the modul form in the backend, the form module loads dead - until it runs into the php_exectuion_time or produces 500 errors - "Premature end of script headers: index.php". (the SQL process that is started is sleeping and will not be aborted)

This only happens if there are 100d of files in the fileadmin. Although the allowed "allowedFileMounts" or "allowedExtensionPaths" are explicitly specified in custom BaseSetup.yaml.
If you move the files from fileadmin to a parent dir / outside of fileadmin - all works fine.


Related issues 2 (2 open0 closed)

Related to TYPO3 Core - Epic #89759: Performance improvements in Forms moduleNew2019-11-24

Actions
Related to TYPO3 Core - Epic #93547: Collection of problems with large sitesAccepted2021-02-19

Actions
Actions #1

Updated by Susanne Moog almost 5 years ago

  • Tags changed from form to form CodingNight
Actions #2

Updated by Christian Hackl almost 5 years ago

I think this is the same problem like this: https://forge.typo3.org/issues/88913

Actions #3

Updated by Christian Hackl almost 5 years ago

  • Related to Bug #88913: link wizard - error 500 - many files directly fileadmin/user_upload/ added
Actions #4

Updated by Riccardo De Contardi over 4 years ago

Are we talking here about EXT:form or the backend interface (so Formengine, I guess)?

Actions #5

Updated by Christian Hackl over 4 years ago

don't no exactly, i think the problem is that the ext:form is searching for the config yaml files and it searches in the complete fileadmin directory insteed of the given "allowedFileMounts" or "allowedExtensionPaths". (looks like)

The link handler from linked issue 88913 above works fine.

Actions #6

Updated by Riccardo De Contardi over 4 years ago

  • Category set to Form Framework
Actions #7

Updated by Björn Jacob over 4 years ago

  • Related to deleted (Bug #88913: link wizard - error 500 - many files directly fileadmin/user_upload/)
Actions #8

Updated by Björn Jacob over 4 years ago

  • Tags deleted (form CodingNight)
  • Sprint Focus set to Remote Sprint
Actions #9

Updated by Mathias Brodala over 4 years ago

  • Status changed from New to Accepted
  • Assignee set to Mathias Brodala
Actions #10

Updated by Mathias Brodala over 4 years ago

  • Due date set to 2019-11-05
  • Start date changed from 2019-07-31 to 2019-11-05
  • Follows Feature #89576: Introduce paginate view helper added
Actions #11

Updated by Mathias Brodala over 4 years ago

This should be fixed with a server-side pagination exactly like the File list module does. For this #89576 would be useful to avoid code duplication.

Actions #12

Updated by Mathias Brodala over 4 years ago

  • Status changed from Accepted to In Progress
Actions #13

Updated by Mathias Brodala over 4 years ago

  • Tags set to performance
Actions #14

Updated by Mathias Brodala over 4 years ago

  • Related to Epic #89759: Performance improvements in Forms module added
Actions #15

Updated by Mathias Brodala over 4 years ago

The pagination idea is handled in #89762 now.

Actions #16

Updated by Mathias Brodala over 4 years ago

  • Sprint Focus deleted (Remote Sprint)
Actions #17

Updated by Sybille Peters over 3 years ago

  • Related to Epic #93547: Collection of problems with large sites added
Actions #18

Updated by Björn Jacob almost 3 years ago

  • Due date deleted (2019-11-05)
  • Status changed from In Progress to Accepted
Actions #19

Updated by Björn Jacob almost 3 years ago

Actions #20

Updated by Björn Jacob almost 3 years ago

  • Status changed from Accepted to Closed
  • Assignee deleted (Mathias Brodala)

The form manager comes in v11 with a pagination. Closing this issue.

Actions

Also available in: Atom PDF