Project

General

Profile

Actions

Bug #88987

closed

Menu Generation Fails on Translated Websites

Added by Ingo Reuter almost 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2019-08-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I'm migrating an TYPO3 project from version 8.7 to 9.5. The project has a single page tree and three different languages (german as default language, english and french).

The main menu consists of three levels and is generated by a fluid data processor:

page.10 = FLUIDTEMPLATE
page.10 {

    ....

    dataProcessing {
        10 = TYPO3\CMS\Frontend\DataProcessing\MenuProcessor
        10 {
            as = mainNavigation
            expandAll = 1
            special = directory
            special.value = [Page ID for menu root]
            levels = 3
        }

    }

}

This code works fine, only if the default language is selected in the frontend. If any other language is selected (in frontend), only entries of the first level are generated and their child objects are empty (do not exist).

The menu generation without special = directory property works fine in all frontend languages:

page.10 = FLUIDTEMPLATE
page.10 {

    ....

    dataProcessing {
        10 = TYPO3\CMS\Frontend\DataProcessing\MenuProcessor
        10 {
            as = mainNavigation
            expandAll = 1
            levels = 3
        }

    }

}

The second snipped generates all three menu levels correctly in all languages.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #88344: HMENU directory incompatible with free modeClosed2019-05-13

Actions
Related to TYPO3 Core - Bug #91185: HMENU does not link to showAccessRestrictedPages for non-default languageClosed2020-04-24

Actions
Actions #1

Updated by Andreas Kie├čling almost 5 years ago

Hi Ingo,

would you mind testing my fix from https://forge.typo3.org/issues/88344?
I ran into an issue with a directory menu and the free mode too, but using the existing menu api instead of the currently used sql query fixed that.

Actions #2

Updated by Riccardo De Contardi almost 5 years ago

  • Category set to Localization
Actions #3

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Needs Feedback

Is this issue still present? #88344 has already been merged 3 months ago

Actions #4

Updated by Georg Ringer over 4 years ago

  • Related to Bug #88344: HMENU directory incompatible with free mode added
Actions #5

Updated by Jonas Eberle about 4 years ago

Yes, the bug is still present in v9 + v10.

Sorry, my bad. I cannot reproduce any more.

This is fixed.

Actions #6

Updated by Jonas Eberle about 4 years ago

  • Related to Bug #91185: HMENU does not link to showAccessRestrictedPages for non-default language added
Actions #7

Updated by Benni Mack about 4 years ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF