Bug #88993

Siteconfig import or symlink breaks TYPO3 if the sourcepath is an deactivated extension

Added by Christian Hackl about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
System/Bootstrap/Configuration
Target version:
-
Start date:
2019-08-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you deliver the siteconfig via extension / distribution and load this config via "import" or as symlink at typo3conf/sites/... and then deactivate this "source" extension, then TYPO3 breaks with error:

YAML File "EXT:..." could not be loaded.

YamlFileLoader.php line 80.

This is not very nice if you have to uninstall the extension for testing or errors or something similar. Because then you always have to comment out the import or rename the symlink or delete altogether, so that you come back into the backend and/or frontend.

Maybe related to https://forge.typo3.org/issues/86803


Related issues

Related to TYPO3 Core - Bug #88306: CKEditor not loading since 9.5.6Closed2019-05-08

Actions
Related to TYPO3 Core - Feature #88330: Optional YAML importsClosed2019-05-10

Actions

Also available in: Atom PDF