Bug #89178

Create multiple pages don't work

Added by Christian Hackl about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-09-15
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Clean new TYPO3 9.5.9 installation.
PHP 7.3.7

Bug 1:
- "Type" selection is empty

Bug 2:
- for Root-Pages - on safe "create pages" -> error:

No pages added
No pages were created.

- for non root-pages - on safe "create pages" -> only one (the last in the list) page is created

screen-capture.webm (277 KB) Christian Hackl, 2019-09-16 16:38

line output.JPG View (95.2 KB) Christian Hackl, 2019-09-16 17:39

History

#1 Updated by Riccardo De Contardi about 1 year ago

We need more information: are you using an admin user or an editor user?

#2 Updated by Christian Hackl about 1 year ago

Admin User - no other user is created, as i sad clean fresh new installation :)
Windows 10 - Chrome 76.0.3809.132

Installed with option ~ create one initial rootpage

Chrome Dev console shows no js error or something

#3 Updated by Andreas Fernandez about 1 year ago

  • Status changed from New to Needs Feedback

I fail to reproduce any of these issues in current 9.5.10-dev. Are you able to xdebug in typo3/sysext/backend/Classes/Controller/Page/NewMultiplePagesController if there is something bogus?

If not, are you able to provide a short screen recording of what you're exactly doing? Maybe we miss an important information.

#4 Updated by Christian Hackl about 1 year ago

I try to look at "typo3/sysext/backend/Classes/Controller/Page/NewMultiplePagesController"... oldschool way if i understand this Class (haven't used xdebug so far).

Short vid what i am try to do in the attached file.

#5 Updated by Christian Hackl about 1 year ago

debug output on line: 136 - for variable/array "{line}" typo3\sysext\backend\Resources\Private\Templates\Page\NewPages.html
Shows array with only strings to xlf files so {line.index} don't work. (Attached file output of {line})

activated extensionlist:
backend
belog
beuser
core
extbase
extensionmanager
felogin
filelist
fluid
fluid_styled_content
frontend
impexp
indexed_search
info
install
lowlevel
recordlist
redirects
reports
rte_ckeditor
seo
setup
tstemplate
viewpage

#6 Updated by Christian Hackl about 1 year ago

I think php Version is the problem - switch back to PHP 7.2.10 clear cache hard - the create multiple pages module works.
On PHP 7.3.7 not.

#7 Updated by Frank Naegler about 1 year ago

on PHP 7.3.8 the module works without any issue

#8 Updated by Riccardo De Contardi about 1 year ago

  • Category set to Backend User Interface

#9 Updated by Riccardo De Contardi 10 months ago

For me, it does not work with PHP 7.3.8 - works with downgrading to 7.2.21

#10 Updated by Christian Hackl 9 months ago

PHP 7.3.9 = don't work
TYPO3 9.5.13 and 10.2.2

#11 Updated by Riccardo De Contardi 8 months ago

I am not able to reproduce it with PHP 7.3.9 and TYPO3 9.5.14 and latest master (10.4.0-dev)

#12 Updated by Susanne Moog 8 months ago

Could this be related to the fluid problems that seem to happen "at random" depending on the PCRE version?

#13 Updated by Christian Hackl 7 months ago

TYPO3 10.3.0 - PHP 7.4.1 it works correctly...
TYPO3 9.5.14 - PHP 7.3.9 it works correctly...

I think this is already fixed.?!

#14 Updated by Georg Ringer 7 months ago

  • Status changed from Needs Feedback to Closed

closed because fixed

Also available in: Atom PDF