Bug #89355

Page tree cuts off page titles horizontally

Added by Christian Eßl about 2 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2019-10-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

See the attached screenshot.
The page tree cuts off page titles that are too long.
Also it doesn't matter if a single page title is just very long or you have a hierarchy of too many subpages. - In both cases, the titles will be cut off.

Two possible solutions come to my mind:
  • Offer horizontal scrolling as soon as a title gets cut off
  • Show the complete page title on mouse hover.

The second solution would probably have its problem with touch devices and would fail on too many page sublevels...


Files

Bildschirmfoto 2019-10-07 um 08.23.54.png (27.7 KB) Bildschirmfoto 2019-10-07 um 08.23.54.png Christian Eßl, 2019-10-07 08:24
overflowing-pagetree.png (18.5 KB) overflowing-pagetree.png Daniel Flaum, 2020-04-22 06:55

Related issues

Related to TYPO3 Core - Bug #84051: SelectTree (Category Tree) - add horizontal scrollingNew2018-02-26

Actions
Related to TYPO3 Core - Feature #78760: Make pagetree panel resizable/expandable on large screensClosed2016-11-21

Actions
Related to TYPO3 Core - Bug #91202: Backend-Pagetree can't scroll horizontallyClosed2020-04-27

Actions
Has duplicate TYPO3 Core - Bug #92157: Page tree not scrollable to right/left in TYPO3 v10Closed2020-09-02

Actions
#1

Updated by Christian Eßl about 2 years ago

  • Related to Bug #84051: SelectTree (Category Tree) - add horizontal scrolling added
#2

Updated by Norman Paschke almost 2 years ago

The page tree already has horizontal scrolling.

#3

Updated by Riccardo De Contardi almost 2 years ago

Horizontal scrolling does not seem to work on 9.5.13 (tested on Windows)

#4

Updated by Riccardo De Contardi almost 2 years ago

  • Related to Feature #78760: Make pagetree panel resizable/expandable on large screens added
#5

Updated by Daniel Flaum over 1 year ago

This issue exists for me in TYPO3 10 in both Firefox 75 and Brave 1.7.92 (the latter is Chromium variant, and is at Chromium 80.0.3987.163). This is on Fedora 31.

In my case, the issue appears because my page tree is exceptionally deep. Screenshot included.

It's important to note that the pagetree in the Link Browser in the RTE does not have this problem--it does scroll from side-to-side when necessary. That pagetree is different from the one provided by the Page module, since it can drill down to individual content elements. But evidently the solution already lurks somewhere in source code. I'll try to locate it.

#6

Updated by Daniel Flaum over 1 year ago

  • Complexity set to easy

I did some experimentation, and found that the pagetree provided by the RTE Link Browser is HTML-based. It's constructed out of a <ul>.

The backend's general pagetree, however, is an <svg>, which has a width attribute set to 100%.

If the <svg>'s width attribute is set to an integer value greater than 300 (which is the current width of the pagetree) then a horizontal scrollbar is provided. Integer values are interpreted as pixel units, and I used a value of 600 to test things myself.

If the width of the <svg> can be calculated whenever the pagetree is redrawn (perhaps by querying the width of the <g class="nodes-wrapper"> which is its immediate child), then the desired functionality will be achieved.

Since the <svg> also has a height attribute whose value is updated when items in the pagetree are expanded and collapsed, I suspect that there is a JavaScript function which is already called at the appropriate times and which already performs almost exactly the desired task. I will therefore set the complexity of this task to easy, and will try now to find the relevant code.

#7

Updated by Riccardo De Contardi over 1 year ago

  • Related to Bug #91202: Backend-Pagetree can't scroll horizontally added
#8

Updated by Stefan P about 1 year ago

  • TYPO3 Version changed from 10 to 9

Why got this changed from v9 to v10? This is a major issue already on v9. We are updating now all v8 setups to v9. And v9 is still labeled LTS and all our setups (which all are quite big with lots of pages) are basically unusable because of this...

There must at least be the posisbility to show the full title as a tooltip on hovering, better would be scrolling. One customer explicitly asked for scrolling because the tree is so deep that resizing would make the edit area to small and unusable instead.

#9

Updated by Stefan P about 1 year ago

  • Is Regression set to Yes

regression because on v8 this was possible

#10

Updated by Stefan P about 1 year ago

Can you make the width of the SVG tree configurable? Currently it's just "100%". A quick-and-dirty solution for me would be to be able to set it to some higher value (like 200% or something) to force the scrollbars.

#11

Updated by Riccardo De Contardi about 1 year ago

  • Related to Bug #92157: Page tree not scrollable to right/left in TYPO3 v10 added
#12

Updated by Riccardo De Contardi about 1 year ago

  • Has duplicate Bug #92157: Page tree not scrollable to right/left in TYPO3 v10 added
#13

Updated by Riccardo De Contardi about 1 year ago

  • Related to deleted (Bug #92157: Page tree not scrollable to right/left in TYPO3 v10)
#14

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#15

Updated by Gerrit Code Review 9 months ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#16

Updated by Gerrit Code Review 9 months ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#17

Updated by Gerrit Code Review 9 months ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#18

Updated by Gerrit Code Review 9 months ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#19

Updated by Gerrit Code Review 9 months ago

Patch set 17 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#20

Updated by Gerrit Code Review 9 months ago

Patch set 18 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/67511

#21

Updated by Benni Mack 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#22

Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed
#23

Updated by Claus Harup about 2 months ago

People might use this in TYPO3 9 & 10:

https://extensions.typo3.org/extension/pagetree_resizable

.... it should be fixed in v.11

Also available in: Atom PDF