Project

General

Profile

Actions

Bug #89580

closed

Sys_language deleted and hidden field are not checked for language select.

Added by Markus Gehrig over 4 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Won't have this time
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2019-11-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TL;DR

The fields Hidden and Deleted are not checked in the page language-select.

User Story

One of our customers has asked to have multiple languages in his system (German, French, Italian and English). For each of these languages, we have added a sys_language record.
Now the customer is filling his content into the site and has realized that he just need (German, French and Italian), English is not needed anymore. So we have deleted all pages translated to English and the sys_language record but you can still select English as a new Translation in a page record.

What's the Problem

A deleted sys_language record shouldn't be used any longer for the language-select in a page record.

Actions #1

Updated by Riccardo De Contardi about 4 years ago

  • Category set to Localization
Actions #2

Updated by Georg Ringer almost 4 years ago

  • Status changed from New to Accepted
Actions #3

Updated by Benni Mack about 1 year ago

  • Status changed from Accepted to Needs Feedback

Hey Markus,

can you give us a bit more details on your setup? We've successfully migrated away from sys_language - hopefully that problem is solved?

Actions #4

Updated by Sybille Peters 12 months ago

I am not 100% sure, but I think even in TYPO3 v9 the language configuration in the site configuration should be relevant and not the records in the database table sys_language. Can you check if it helps if you delete the language from the site configuration?

In any case, it might help to post your site configuration.

Actions #5

Updated by Jo Hasenau 7 months ago

  • Priority changed from Should have to Won't have this time

Since this is an issue about a table that has been fully removed in current versions, it is most likely that the issues will not be fixed at all.
Each of the versions still containing the table are at least in priority bugfixing phase or even on ELTS. So I will close issue as won't have.

Actions #6

Updated by Jo Hasenau 7 months ago

  • Status changed from Needs Feedback to Closed
Actions

Also available in: Atom PDF