Bug #89989

Since v9.5.12 extendToSubpages has no effect for subpages in menus

Added by Patrick no-lastname-given 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2019-12-18
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Since TYPO3 9.5.12, subpages of a access protected page with enabled extendToSubpages option are still visible in a frontend menu.

Scenario

backend pagetree example:
  • Parentpage (Usergroup Access Rights: Show at any login, Extend to Subpages: enabled, Page enabled in menus: disabled)
    • Subpage 1 (Page enabled in menus: enabled)
    • Subpage 2 (Page enabled in menus: enabled)
    • ...

menu processor:

page.10.dataProcessing.30 = TYPO3\CMS\Frontend\DataProcessing\MenuProcessor
page.10.dataProcessing.30 {
    special = directory
    special.value = {$mainmenuPid}
    levels = 4
    expandAll = 1
    includeSpacer = 1
    titleField = nav_title // title
    as = mainmenu
}

Even if the user group rights of the parent page are set to "Show at every login" and "extend to subpages" is enabled, the subpages are visible in the menu for public visitors who are not logged in.


Related issues

Related to TYPO3 Core - Bug #88344: HMENU directory incompatible with free mode Closed 2019-05-13
Duplicated by TYPO3 Core - Bug #90971: HMENU regression in 9.5.12 Closed 2020-04-07

Associated revisions

Revision ef08345d (diff)
Added by Georg Ringer 3 months ago

[BUGFIX] Revert Use existing API instead of ContentObjectRenderer"

This reverts commit 47e63fc33c7dd45111465d833216eb474f224b9e
because of regressions.

Resolves: #89989
Reverts: #88344
Releases: master, 9.5
Change-Id: I1f43d0f343484366e81581435bdb418cfebf317a
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62832
Tested-by: Benni Mack <>
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Reviewed-by: Benni Mack <>
Reviewed-by: Georg Ringer <>

Revision ae722d64 (diff)
Added by Georg Ringer 3 months ago

[BUGFIX] Revert Use existing API instead of ContentObjectRenderer"

This reverts commit 47e63fc33c7dd45111465d833216eb474f224b9e
because of regressions.

Resolves: #89989
Reverts: #88344
Releases: master, 9.5
Change-Id: I1f43d0f343484366e81581435bdb418cfebf317a
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/64151
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Patrick no-lastname-given 7 months ago

  • Description updated (diff)

#2 Updated by Georg Ringer 7 months ago

  • Related to Bug #88344: HMENU directory incompatible with free mode added

#3 Updated by Georg Ringer 7 months ago

could be related to #88344. can you locally revert https://review.typo3.org/c/Packages/TYPO3.CMS/+/62527 and check if it works then?

#4 Updated by Patrick no-lastname-given 7 months ago

Georg Ringer wrote:

could be related to #88344. can you locally revert https://review.typo3.org/c/Packages/TYPO3.CMS/+/62527 and check if it works then?

I can confirm that a revert of https://review.typo3.org/c/Packages/TYPO3.CMS/+/62527 fixes this issue.

#5 Updated by Paul Beck 7 months ago

I also have massive problems with menues using a specific entryLevel which are not working correctly anymore. But my system has nothing to do with access rights / extendToSubpages.
So probably my problem with the entryLevel is a new issue but it also gets solved when I use the above mentioned revert of https://review.typo3.org/c/Packages/TYPO3.CMS/+/62527

#6 Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62832

#7 Updated by Susanne Moog 6 months ago

  • Sprint Focus set to On Location Sprint

#8 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62832

#9 Updated by Patrick no-lastname-given 4 months ago

Gerrit Code Review wrote:

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62832

Any news here? Issue still exist with 9.5.14

#10 Updated by Patrick no-lastname-given 3 months ago

Patrick no-lastname-given wrote:

Gerrit Code Review wrote:

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62832

Any news here? Issue still exist with 9.5.14

Issue still exist with 9.5.15.
Current Workaround: patch typo3/cms-frontend with composer

#11 Updated by Georg Ringer 3 months ago

  • Duplicated by Bug #90971: HMENU regression in 9.5.12 added

#12 Updated by Georg Ringer 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#13 Updated by Gerrit Code Review 3 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64151

#14 Updated by Georg Ringer 3 months ago

  • Status changed from Under Review to Resolved

#15 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF