Bug #91772

Show hidden records does not work as expected.

Added by Markus Gehrig over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Target version:
-
Start date:
2020-07-09
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

User Story

Our customer wants to check new content elements in the frontend before publishing. So he sets the elements to hidden and wants to show it with the admin panel. In Version 8 LTS this works without a problem. But in Version 9 LTS the hidden records are not shown.

Fronted End:

TypoScript:

The implementation in the TypoScript looks like this:

    20 = CONTENT
    20 {
        table = tt_content
        select {
            includeRecordsWithoutDefaultTranslation = 1
            orderBy = sorting
            where = {#colPos}={register:colPos}
            where.insertData = 1
            pidInList.data = register:pageUid
            pidInList.override.data = register:contentFromPid
        }
        renderObj{
            stdWrap{
                dataWrap = {register:elementWrap}
                required = 1
            }
        }
        stdWrap {
            dataWrap = {register:wrap}
            required = 1
        }
    }

SQL:

The SQL in the Admin Panel looks like this. Watch for the hidden = 0 in the where clause.

SELECT * FROM `tt_content` WHERE ((`tx_gridelements_container` = :dcValue1) AND (`colPos` <> :dcValue2) AND (`pid` = :dcValue3) AND (`tx_gridelements_columns` IN (:dcValue4)) AND (`sys_language_uid` IN (:dcValue5))) AND ((`tt_content`.`deleted` = 0) AND ((`tt_content`.`t3ver_state` <= 0) AND (`tt_content`.`pid` <> -1)) AND (`tt_content`.`hidden` = 0) AND (`tt_content`.`starttime` <= 1594284300) AND ((`tt_content`.`endtime` = 0) OR (`tt_content`.`endtime` > 1594284300)) AND ((`tt_content`.`fe_group` IS NULL) OR (`tt_content`.`fe_group` = '') OR (`tt_content`.`fe_group` = '0') OR (FIND_IN_SET('0', `tt_content`.`fe_group`)) OR (FIND_IN_SET('-1', `tt_content`.`fe_group`)))) ORDER BY `sorting` ASC

Files


Related issues

Is duplicate of TYPO3 Core - Bug #91083: Preview setting "showHiddenRecords" in the admin panel does not work.ClosedChristian Eßl2020-04-17

Actions
#1

Updated by Markus Gehrig over 1 year ago

  • Description updated (diff)
#2

Updated by Markus Gehrig over 1 year ago

  • Subject changed from Verborgene Datensätze anzeigen does not work as expected. to Show hidden records does not work as expected.
#3

Updated by Kurt Gusbeth over 1 year ago

I can confirm, that hidden records (elements of an extension) are not displayed even with the Admin Panel.
The feature "show hidden records" worked in version 9.5.14, but this feature is not working anymore in version 9.5.19.
This must be a bug in a newer TYPO3 version.

#4

Updated by Chris Müller over 1 year ago

  • Is duplicate of Bug #91083: Preview setting "showHiddenRecords" in the admin panel does not work. added
#5

Updated by Christian Eßl about 1 year ago

  • Status changed from New to Resolved
#6

Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF