Bug #91083

Preview setting "showHiddenRecords" in the admin panel does not work.

Added by Tom Lachemund over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
AdminPanel
Target version:
-
Start date:
2020-04-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,
since the last update the display of hidden records in the "View" module has stopped working.
The adminpanel is installed and activated and the setting "showHiddenRecords" is set.
When we downgrade to 9.5.14 all works as expected.

Version: 9.5.15
PHP: 7.2.29


Related issues

Related to TYPO3 Core - Bug #86653: Preview of page, with "show", not working when starttime is setClosed2018-10-14

Actions
Related to TYPO3 Core - Bug #91225: TYPO3 v9.1.15 Admin-Panel, Simulate FE-Time not workingNew2020-04-28

Actions
Related to TYPO3 Core - Bug #92242: Problem after updating to TYPO3 9.5.21 w adminpanel: Page is cached with hidden elements and is served with these elements even if not logged inClosed2020-09-09

Actions
Has duplicate TYPO3 Core - Bug #91772: Show hidden records does not work as expected. Closed2020-07-09

Actions
#1

Updated by Chris Müller over 1 year ago

I can confirm this behaviour since the last update.

#2

Updated by Maik Matthias over 1 year ago

Same problem with TYPO3 9.5.16
In my opinion this is a "must have", because the preview function is very important for content editors.

#3

Updated by Thomas Hempel over 1 year ago

Can confirm for 9.5.17

#4

Updated by Christian Eßl over 1 year ago

  • Assignee set to Christian Eßl
#5

Updated by Christian Eßl over 1 year ago

  • Related to Bug #86653: Preview of page, with "show", not working when starttime is set added
#6

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64491

#7

Updated by DANIEL Rémy over 1 year ago

  • Related to Bug #91225: TYPO3 v9.1.15 Admin-Panel, Simulate FE-Time not working added
#8

Updated by Chris Müller over 1 year ago

  • Has duplicate Bug #91772: Show hidden records does not work as expected. added
#9

Updated by Chris Müller over 1 year ago

In 10.4.5 I also have the behaviour, that the hidden pages/records setting works for an admin user, but not for an editor.

#10

Updated by Oliver Schmidt over 1 year ago

We have the same problem on TYPO3 V. 9.5.19, PHP V. 7.4.3. Testet with admin and user.

#11

Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/64491

#12

Updated by Christian Eßl over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#13

Updated by Oliver Hader about 1 year ago

  • Related to Bug #92242: Problem after updating to TYPO3 9.5.21 w adminpanel: Page is cached with hidden elements and is served with these elements even if not logged in added
#14

Updated by DANIEL Rémy about 1 year ago

This fix introduced a regression: #92242

#15

Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF