Project

General

Profile

Actions

Bug #92045

closed

Story #92091: PageTree related flaws TYPO3 v9.5.20/21-dev or v10.4.6/7-dev

Pagetree shows pages twice

Added by Christian Matthes almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2020-08-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

After updating to 9.5.20 the page treee shows all pages (type = standard, rootlevel = 1) twice.

In my opinion this could be caused by following js error:

New in 9.5.20: call of "switchFocusNode" in
/sysext/backend/Resources/Public/JavaScript/PageTree/PageTree.js (line 342)

This is obviously backported from 10.4 (exists since 10.2). Unfortunately the definition of "switchFocusNode" didn't find its way back to 9.5.20.
It can be found in 10.2.0 in
/sysext/backend/Resources/Public/JavaScript/SvgTree.js (line 379)

I think not only the call but also the definition of function "switchFocusNode" should be present in 9.5.x


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91878: Fatal error in pagetree 9.5.20Closed2020-07-28

Actions
Actions #1

Updated by Christian Matthes almost 4 years ago

  • Description updated (diff)
Actions #2

Updated by Bastian Bringenberg almost 4 years ago

  • Project changed from 9 to TYPO3 Core
  • TYPO3 Version set to 9

Moved to right Project. Adjusted TYPO3 Version.

Actions #3

Updated by Oliver Hader almost 4 years ago

  • Category set to Pagetree
Actions #4

Updated by Oliver Hader almost 4 years ago

  • Is Regression set to Yes
Actions #5

Updated by Oliver Hader almost 4 years ago

  • Related to Bug #91878: Fatal error in pagetree 9.5.20 added
Actions #6

Updated by Oliver Hader almost 4 years ago

  • Status changed from New to Needs Feedback

This (hopefully) was handled in #91878 - can you please check whether the problem (or other/new issues) exist with the patch at https://review.typo3.org/c/Packages/TYPO3.CMS/+/65355
Thanks in advance for your feedback!

Actions #7

Updated by Christian Matthes almost 4 years ago

Sorry didn't recognize the connection to #91878.
The mentioned patch fixes my issue.

Thanks a lot.

Actions #8

Updated by Oliver Hader over 3 years ago

  • Status changed from Needs Feedback to Closed

Thx for the response, closing this issue

Actions #9

Updated by Oliver Hader over 3 years ago

  • Parent task set to #92091
Actions

Also available in: Atom PDF