Project

General

Profile

Actions

Bug #92045

closed

Story #92091: PageTree related flaws TYPO3 v9.5.20/21-dev or v10.4.6/7-dev

Pagetree shows pages twice

Added by Christian Matthes almost 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2020-08-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

After updating to 9.5.20 the page treee shows all pages (type = standard, rootlevel = 1) twice.

In my opinion this could be caused by following js error:

New in 9.5.20: call of "switchFocusNode" in
/sysext/backend/Resources/Public/JavaScript/PageTree/PageTree.js (line 342)

This is obviously backported from 10.4 (exists since 10.2). Unfortunately the definition of "switchFocusNode" didn't find its way back to 9.5.20.
It can be found in 10.2.0 in
/sysext/backend/Resources/Public/JavaScript/SvgTree.js (line 379)

I think not only the call but also the definition of function "switchFocusNode" should be present in 9.5.x


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #91878: Fatal error in pagetree 9.5.20Closed2020-07-28

Actions
Actions

Also available in: Atom PDF