Task #92619

Epic #89595: Improve accessibility of backend

Login button has an invalid attribute

Added by Mark Leutl about 1 month ago. Updated 25 days ago.

Status:
On Hold
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2020-10-21
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
accessibility
Complexity:
easy
Sprint Focus:

Description

The login button contains the attribute "autocomplete" which is not allowed with <button>. #tas2020 TYPO3-8

#1

Updated by Riccardo De Contardi about 1 month ago

  • Parent task set to #89595
#2

Updated by Gerrit Code Review about 1 month ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66317

#3

Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 10.4 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/66335

#4

Updated by Mark Leutl about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Christian Kuhn about 1 month ago

Patch has been merged to master and will be reverted there again because firefox acts funny. Requested 10.4 backport has not been merged.

#6

Updated by Jonas Eberle 30 days ago

What were the problems with Firefox like?

#7

Updated by Martin Kutschker 26 days ago

What are the issues? I have tried the patch and had no issues.

#8

Updated by Michael Telgkamp 25 days ago

  • Status changed from Resolved to On Hold

As stated in the master merge request there is currently a bug with Firefox. The disabled state of a button might be persisted - see https://developer.mozilla.org/en-US/docs/Web/HTML/Element/button#attr-autocomplete and the bug at https://bugzilla.mozilla.org/show_bug.cgi?id=654072

Without the additional autocomplete attribute it can happen, that there is a disabled button on the login page, although it should be active. This can break the login completely.

While the Firefox bug is still open, the patch for this bug should not be merged.

#9

Updated by Martin Kutschker 25 days ago

Incredibly stupid and long standing FF bug. Funny I have never (as FF user) seen it in the wild.

Anyways, I'm not in the camp who removes attributes that are marked as wrong by a validator just because.

Thanks for the clarification.

Also available in: Atom PDF