Project

General

Profile

Actions

Bug #92865

closed

10.4.10 breaks compatibility with doctrine/dbal 2.12

Added by Christian Spoo over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
composer
Target version:
Start date:
2020-11-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

The 10.4.10 release changed TYPO3's dependencies. It now requires

doctrine/dbal: ~2.10.0 || ~2.11.2

whereas 10.4.9 required
doctrine/dbal: ^2.10

Since ~2.11.2 is the same as >=2.11.2,<2.12.0. Composer will most likely try to install doctrine/dbal 2.11.3 (the most recent 2.11 version). If you have installed doctrine/dbal >=2.12 or have other dependencies that require doctrine/dbal 2.12 (which was fine before), this will prevent you from updating to TYPO3 10.4.10, keeping you at 10.4.9.

Since doctrine/dbal 2.12.1 worked fine with TYPO3 10.4.9 before and TYPO3 now prevents me from working with this version, I almost consider this as a textbook example of a regression. Additional, the 10.4.10 release notes do not state any database-related issues, so no reason why TYPO3 should exclude 2.12 - especially since versions <= 2.11 are officially unmaintained (see https://www.doctrine-project.org/projects/doctrine-dbal/en/2.11/reference/introduction.html#introduction).


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #92376: Doctrine 2.11.x breaks prepared parametersClosedMarkus Klein2020-09-22

Actions
Related to TYPO3 Core - Task #93848: Add compatibility with Doctrine DBAL 2.13.xClosedBenni Mack2021-04-01

Actions
Actions #1

Updated by Oliver Hader over 3 years ago

  • Related to Bug #92376: Doctrine 2.11.x breaks prepared parameters added
Actions #3

Updated by Riccardo De Contardi almost 3 years ago

  • Related to Task #93848: Add compatibility with Doctrine DBAL 2.13.x added
Actions #4

Updated by Riccardo De Contardi almost 3 years ago

As far as I can see on TYPO3 10.4.16 the file:

/typo3/sysext/core/composer.json reads

"doctrine/dbal": "~2.10.0 || ~2.11.2 || ~2.13.1",
Actions #5

Updated by Benni Mack over 2 years ago

  • Status changed from New to Closed

As discussed with the author of the ticket, I will close this one, as this has been resolved in recent v10.4 bugfix versions.

Actions

Also available in: Atom PDF