Bug #93798

Error for f:form.checkbox or f:form.radio without property attribute

Added by Jonas Götze 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2021-03-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
7.4
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Using f:form.checkbox or f:form.radio without a property-attribute inside a f:form with object="..." attribute leads to the error

Argument 2 passed to TYPO3\CMS\Extbase\Reflection\ObjectAccess::getPropertyPath() must be of the type string, null given, called in /var/www/html/private/typo3/sysext/fluid/Classes/ViewHelpers/Form/AbstractFormFieldViewHelper.php on line 311

This is due to ObjectAccess::getPropertyPath expects its second parameter to be a string (strict_types), which has been changed in 10.0 via #87332.


Related issues

Related to TYPO3 Core - Task #87332: Avoid runtime reflection calls in ObjectAccessClosedAlexander Schnitzler2019-01-04

Actions

Also available in: Atom PDF