Project

General

Profile

Actions

Bug #93942

closed

Remove Imagecropping at SVG Files?

Added by Michael Kasten about 3 years ago. Updated 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Image Cropping
Target version:
Start date:
2021-04-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
13
PHP Version:
8.1
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

Testet on https://demo.typo3.org (10.4.14):

  • Upload a svg File
  • Create a text/media CE
  • Choose the svg as media
  • Crop the image
  • Save the content -> Quits with an Error
  • Editing is not possible fourthermore exept deleting this CE in Listview

I guess maybe it would better to create a set of possible image formats for the cropping tool?


Files


Related issues 2 (2 open0 closed)

Related to TYPO3 Core - Bug #77190: ImageMainpulation for SVG only scales but does not cropNew2016-07-21

Actions
Related to TYPO3 Core - Epic #101608: File Abstraction Layer Changes for v13New2019-06-11

Actions
Actions #1

Updated by Martin Kutschker about 3 years ago

Technically it could be cropped by modifying the SVG element's attributes.

Actions #2

Updated by Garvin Hicking 9 months ago

  • Target version set to 13.0
  • TYPO3 Version changed from 10 to 13
  • PHP Version set to 8.1
  • Complexity changed from easy to medium

I took the liberty to hijack this issue to implement SVG imagecropping.

PR incoming.

Actions #3

Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #4

Updated by Gerrit Code Review 9 months ago

Patch set 2 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #5

Updated by Gerrit Code Review 9 months ago

Patch set 3 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #6

Updated by Gerrit Code Review 9 months ago

Patch set 4 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #7

Updated by Gerrit Code Review 9 months ago

Patch set 5 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #8

Updated by Gerrit Code Review 9 months ago

Patch set 6 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #9

Updated by Gerrit Code Review 9 months ago

Patch set 7 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #10

Updated by Gerrit Code Review 9 months ago

Patch set 8 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #11

Updated by Gerrit Code Review 9 months ago

Patch set 9 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #12

Updated by Gerrit Code Review 9 months ago

Patch set 10 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #13

Updated by Gerrit Code Review 8 months ago

Patch set 11 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #14

Updated by Gerrit Code Review 8 months ago

Patch set 12 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #15

Updated by Gerrit Code Review 8 months ago

Patch set 13 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #16

Updated by Gerrit Code Review 8 months ago

Patch set 14 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #17

Updated by Benni Mack 8 months ago

  • Related to Bug #77190: ImageMainpulation for SVG only scales but does not crop added
Actions #18

Updated by Gerrit Code Review 8 months ago

Patch set 15 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #19

Updated by Garvin Hicking 8 months ago

The current patch set 15 seems to work well with a content image crop.

It also works when using i.e. a flexform or a custom content element and <f:image> with an image=... FAL reference.

However, it does not work when using a <f:image src="..."> definition. Probably because $task->getTargetFile()->updateProcessingUrl(...) is only used for file references with attached crops, but not locally sourced static files? Sadly I don't know where to dig in the reorganized code to make it work for this. The SVG is passed through, but the '#svgBox...' URI fragment is missing.

Bonus task: Currently it seems using <f:image ... fileExtension="png"> does NOT enforce rending an SVG through a PNG process.

I've created a simple extension showcasing the issue (required applied patch):

https://github.com/garvinhicking/gh_svg_crop

Actions #20

Updated by Christian Kuhn 7 months ago

  • Related to Epic #101608: File Abstraction Layer Changes for v13 added
Actions #21

Updated by Gerrit Code Review 7 months ago

Patch set 16 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #22

Updated by Gerrit Code Review 6 months ago

Patch set 17 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #23

Updated by Gerrit Code Review 6 months ago

Patch set 18 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #24

Updated by Gerrit Code Review 6 months ago

Patch set 19 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #25

Updated by Gerrit Code Review 6 months ago

Patch set 20 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #26

Updated by Gerrit Code Review 5 months ago

Patch set 21 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #27

Updated by Gerrit Code Review 5 months ago

Patch set 22 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #28

Updated by Gerrit Code Review 5 months ago

Patch set 23 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #29

Updated by Gerrit Code Review 5 months ago

Patch set 24 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #30

Updated by Gerrit Code Review 5 months ago

Patch set 25 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #31

Updated by Gerrit Code Review 5 months ago

Patch set 26 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #32

Updated by Gerrit Code Review 5 months ago

Patch set 27 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #33

Updated by Gerrit Code Review 5 months ago

Patch set 28 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #34

Updated by Gerrit Code Review 5 months ago

Patch set 29 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #35

Updated by Gerrit Code Review 4 months ago

Patch set 30 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #36

Updated by Gerrit Code Review 4 months ago

Patch set 31 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #37

Updated by Gerrit Code Review 4 months ago

Patch set 32 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #38

Updated by Gerrit Code Review 4 months ago

Patch set 33 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #39

Updated by Benni Mack 4 months ago

  • Target version changed from 13.0 to 13.1
Actions #40

Updated by Gerrit Code Review 4 months ago

Patch set 34 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #41

Updated by Gerrit Code Review 3 months ago

Patch set 35 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #42

Updated by Gerrit Code Review 3 months ago

Patch set 36 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #43

Updated by Gerrit Code Review 3 months ago

Patch set 37 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #44

Updated by Gerrit Code Review 3 months ago

Patch set 38 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #45

Updated by Gerrit Code Review 3 months ago

Patch set 39 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #46

Updated by Gerrit Code Review 3 months ago

Patch set 40 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #47

Updated by Gerrit Code Review 3 months ago

Patch set 41 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #48

Updated by Gerrit Code Review 3 months ago

Patch set 42 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #49

Updated by Gerrit Code Review 3 months ago

Patch set 43 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #50

Updated by Gerrit Code Review 3 months ago

Patch set 44 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #51

Updated by Gerrit Code Review 2 months ago

Patch set 45 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #52

Updated by Gerrit Code Review 2 months ago

Patch set 46 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #53

Updated by Gerrit Code Review 2 months ago

Patch set 47 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #54

Updated by Gerrit Code Review 2 months ago

Patch set 48 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #55

Updated by Gerrit Code Review 2 months ago

Patch set 49 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #56

Updated by Gerrit Code Review 2 months ago

Patch set 50 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #57

Updated by Gerrit Code Review 2 months ago

Patch set 51 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #58

Updated by Gerrit Code Review 2 months ago

Patch set 52 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #59

Updated by Gerrit Code Review 2 months ago

Patch set 53 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #60

Updated by Gerrit Code Review 2 months ago

Patch set 54 for branch main of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/80617

Actions #61

Updated by Garvin Hicking 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF