Project

General

Profile

Actions

Feature #95515

closed

Save and Close button

Added by Robert von Hackwitz almost 3 years ago. Updated 14 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2021-10-07
Due date:
% Done:

0%

Estimated time:
PHP Version:
7.4
Tags:
backend usability, backend workflow
Complexity:
Sprint Focus:

Description

It could be useful to have a "Save and Close button" on top of BE Editing Form


Related issues 2 (1 open1 closed)

Related to TYPO3 Core - Epic #93528: Backlog of UX ideas for EditorsNew2010-11-11

Actions
Related to TYPO3 Core - Bug #87812: Feature TSconfig options.saveDocCloseRejected2019-02-28

Actions
Actions #1

Updated by Benni Mack almost 3 years ago

  • Target version changed from 11 LTS to Candidate for Major Version
Actions #2

Updated by Sybille Peters about 2 years ago

  • Tags set to backend usability, backend workflow

just as a fyi:

There are currently 2 extensions (AFAIK) which provide this functionality: save_close_ce and kf_backend_mod . Both break the slug / redirect revert functionality from the core.

Actions #3

Updated by Sybille Peters almost 2 years ago

Update: with save_close_ce dev-master and TYPO3 v11 the problem is no longer reproducable: the extension does not break the redirect revert functionality.

Actions #4

Updated by Sybille Peters about 1 year ago

  • Related to Epic #93528: Backlog of UX ideas for Editors added
Actions #5

Updated by Riccardo De Contardi 17 days ago

There's also https://extensions.typo3.org/extension/save_and_close which works with TYPO3 12

Actions #6

Updated by Riccardo De Contardi 14 days ago

  • Related to Bug #87812: Feature TSconfig options.saveDocClose added
Actions #7

Updated by Riccardo De Contardi 14 days ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for Major Version)

I feel sorry to reject this issue, but the decision to remove the "save and close" button has been already taken and goes in the direction of simplifying the TYPO3 backend and is not going to be reimplemented.

- On version 13.1 it has been implemented a "save and close" hotkey https://docs.typo3.org/c/typo3/cms-core/main/en-us/Changelog/13.1/Feature-103529-IntroduceHotkeyForSaveAndClose.html

- On version 12 you could use a third-party extension https://extensions.typo3.org/extension/save_and_close

If you think that this is the wrong decision, then please reopen it or open a new ticket and add a relation to this ticket number.

Actions

Also available in: Atom PDF