Project

General

Profile

Actions

Bug #104139

closed

Broken ready state in TYPO3 backend with Chrome 126.0.6478.62

Added by Andreas Kienast 29 days ago. Updated 22 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2024-06-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
11
PHP Version:
Tags:
Complexity:
nightmare
Is Regression:
Sprint Focus:

Description

After upgrading to Chrome 126.0.6478.62, the TYPO3 backend becomes unresponsive pretty quick.
The symptom is that loading certain backend modules (e.g. "List") and using the page tree seems to take forever, as the loading bar doesn't disappear after a few clicks.

After some investigation it has been revealed that this behavior happens with Chrome 126.0.6478.62, the previous version 126.0.6478.61 is not affected. The only change in this version is a partial revert of a SVG-related change, also see the related ticket.

After disabling the SvgSpriteIconProvider, the issue is gone:

diff --git a/typo3/sysext/core/Classes/Imaging/IconProvider/SvgSpriteIconProvider.php b/typo3/sysext/core/Classes/Imaging/IconProvider/SvgSpriteIconProvider.php
index c10c3b31f3..f48b7c6b31 100644
--- a/typo3/sysext/core/Classes/Imaging/IconProvider/SvgSpriteIconProvider.php
+++ b/typo3/sysext/core/Classes/Imaging/IconProvider/SvgSpriteIconProvider.php
@@ -38,7 +38,7 @@ class SvgSpriteIconProvider extends AbstractSvgIconProvider
         }

         $source = $options['sprite'];
-        return '<svg class="icon-color"><use xlink:href="' . htmlspecialchars($this->getPublicPath($source)) . '" /></svg>';
+        return '';
     }

     /**

We're either dealing with a edge-case here that is triggered by our SVG files, or we run into a Chromium regression – Firefox and Safari both are NOT affected.

It turns out that some promises get rejected after 30 seconds, which can be seen in the browser console. This is a special behavior of the @typo3/core/document-service module. The reason is that the iframe is stuck in the ready state interactive and never transitions to complete. This race condition is a follow-up error that will be handled with #104315:


Files


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #104135: Improve document-service responsivenessClosed2024-06-18

Actions
Actions #1

Updated by Benjamin Franzke 29 days ago

  • Related to Bug #104135: Improve document-service responsiveness added
Actions #2

Updated by Andreas Kienast 29 days ago

  • Description updated (diff)
Actions #3

Updated by Andreas Kienast 29 days ago

  • Description updated (diff)
Actions #4

Updated by Benjamin Franzke 29 days ago

  • Description updated (diff)
Actions #5

Updated by Benjamin Franzke 29 days ago

Actions #6

Updated by Andreas Kienast 28 days ago

Actions #7

Updated by Garvin Hicking 28 days ago

  • Category set to Backend User Interface
Actions #8

Updated by Georg Ringer 22 days ago

  • Status changed from Accepted to Closed

chrome 126.0.6478.127 is available which fixed it, therefore closing issue

thanks to everyone involved

Actions

Also available in: Atom PDF