Project

General

Profile

Actions

Bug #11336

closed

Make error message more user friendly

Added by Roland Behme over 13 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2010-12-08
Due date:
% Done:

80%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Some error messages are not very userfriendly at the moment and are quite impossible to understand for a normal editor.

Example:
1: [newlog()] Could not be edited in offline workspace in the branch where found (failure state: 'Record stage "1" and users access level did not allow for editing'). Auto-creation of version not allowed in workspace!

Says that the record I tried to edit is already in review state and can therefore not be edited. But to find out what the error message says one needs not so common understanding of the TYPO3 workspace mechanics ...


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #27643: Element editing is restricted if editor has no right to the related WS-stageClosedTolleiv Nietsch2011-06-22

Actions
Related to TYPO3 Core - Feature #10551: Improve handling of non-versionable recordsClosedOliver Hader2010-10-31

Actions
Actions #1

Updated by Tolleiv Nietsch over 13 years ago

  • Status changed from New to Accepted
  • Target version set to 4.6
Actions #2

Updated by Tolleiv Nietsch almost 13 years ago

  • TYPO3 Version set to 4.6

was pretty much solved with #27643 - the message itself didn't really change yet but there's a "nice" warning which pops up directly.

Actions #3

Updated by Tolleiv Nietsch almost 13 years ago

  • % Done changed from 0 to 80
Actions #4

Updated by Michael Stucki over 10 years ago

  • Category set to Workspaces
Actions #5

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
  • Target version deleted (4.6)
Actions #6

Updated by Mathias Schreiber over 9 years ago

  • Target version set to 7.5
Actions #7

Updated by Benni Mack over 8 years ago

  • Target version changed from 7.5 to 7 LTS
Actions #8

Updated by Mathias Schreiber over 8 years ago

  • Target version deleted (7 LTS)
Actions #9

Updated by Oliver Hader over 8 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

Duplicate of #10551

Actions

Also available in: Atom PDF