Bug #15215

Broken Rootline when a Editor view a Page that is not online

Added by Manfred Rutschmann almost 16 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Category:
Workspaces
Target version:
-
Start date:
2005-11-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When i make a Version from a Page+Content and i logged in as a Editor, i cant´t Vie the Version that is not Online. I recived an Broken Rootline Error:

The requested page didn't have a proper connection to the tree-root!

(Broken rootline)

The admin User don´t have any problems with the extension.

Install the Extension "Version"
Make a BE Group
Make a Editor
Log In as Editor
Click on a Site in the Tree
Click on Versioning
Make a Page+Content Copy from the SIte
View the new Site that is NOT Online
Have an Error :(

(issue imported from #M1893)


Files

bug_1839.txt (5.13 KB) bug_1839.txt Administrator Admin, 2007-04-18 13:58
bug_1839_v2.txt (10.2 KB) bug_1839_v2.txt Administrator Admin, 2007-05-02 10:50

Related issues

Related to TYPO3 Core - Bug #17924: Versioning clickMenu option only available for Admin UserClosed2007-12-15

Actions
Related to TYPO3 Core - Bug #17816: Broken Rootline when a editor views a draft version in LiveworkspaceClosed2007-11-20

Actions
Related to TYPO3 Core - Bug #21706: Broken rootline when previewing versioned pages (not workpaces)Closed2009-11-26

Actions
#1

Updated by Administrator Admin almost 15 years ago

This error is still occuring when previewing a new version of a page by an editor (or generally by any user in the workflow)
It does not occur when previewing a new page.

I am using 4.0.3 with sys_workflows 2.5.1

Apparently the pid -1 in the page record causes this, at least: if I change it into the real pid, the problem does not occur. But the new version is then counted as real page and therefore the page will occur twice in the pagetree.

--------------------------
Error!

The requested page didn't have a proper connection to the tree-root!

(Broken rootline)
--------------------------

btw: I have been checking the sys_workflows configuration for possible errors but cannot find any which would lead to this behaviour.

Regards,
Pascal

#2

Updated by Typoheads - Web Engineering almost 15 years ago

steps to reproduce:

Install the Extension "Version" (should be in any case..)
Make a BE Group
Make a Editor
Log In as Editor
Click on a Site in the Tree
Click on Versioning
Make a Page+Content Copy from the SIte
View the new Site that is NOT Online
Have an Error :(

#3

Updated by Oliver Hader almost 15 years ago

Boris, what TYPO3 version does your report refer to? TYPO3 3.8.x?

#4

Updated by Typoheads - Web Engineering almost 15 years ago

4.0.3, 4.0.4

#5

Updated by Andreas Balzer over 14 years ago

and it is fully reproducable by the way... :-/

#6

Updated by Dmitry Dulepov over 14 years ago

I think I fixed that. Patch is posted to core list and should in SVN soon.

#7

Updated by Dmitry Dulepov over 14 years ago

Btw, bug_1839.txt fixes the problem when editor is NOT in Live. Live workspace still have this problem.

#8

Updated by Dmitry Dulepov over 14 years ago

2nd version of the patch fixes the problem.

#9

Updated by Dmitry Dulepov over 14 years ago

Hi Pascal!

I belive the issue is fixed. If you are still willing to pay for the fix, could you could check latest SVN version and let me know if it works for you?

Regards,
Dmitry.

#10

Updated by Dmitry Dulepov over 14 years ago

I had to set status back to assigned because it does not let to add comments when set to "resolved" :(

#11

Updated by Pascal no-lastname-given over 14 years ago

Hi Dmitry,

thanks for fixing it.
I had already setup a workaround for it by creating a custom workspace.
(I did try to find a way to remove the sponsorship but did not find it)
But since it still was mentioned on the issue, I will pay for it.
Next week I have some time to do the testing and report back to you.

Good thing you reminded me, I also still have to make a contribution to the Typo3 project :-)

Greetings,
Pascal

#12

Updated by Dmitry Dulepov over 14 years ago

Hi Pascal!

Thanks for the reply. I think we can continue off the list. My e-mail is . Please, feel free to contact when you have time :)

Dmitry.

#13

Updated by Oliver Hader over 14 years ago

This was committed to 4.1 and Trunk by Dmitry on 20th of April 2007.

#14

Updated by Michael Stucki almost 8 years ago

  • Category set to Workspaces
#15

Updated by Michael Stucki almost 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
  • Target version deleted (0)

Also available in: Atom PDF