Bug #17816

Broken Rootline when a editor views a draft version in Liveworkspace

Added by Jolanda Reber about 13 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2007-11-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.1
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a editor wants to preview a draft version in the liveworkspace the following error is shown:
"The requested page didn't have a proper connection to the tree-root!
(Broken rootline)"

This error does not occur if the user has administration rights.

TYPO3 Version 4.1.3

The same or a similar issue was already reported and should have been resolved in version 4.1.2.

  • Fixed bug #1893: Broken Rootline when a Editor view a Page that is not online
    (issue imported from #M6772)

Files

preview_bug.patch (847 Bytes) preview_bug.patch Administrator Admin, 2009-11-03 13:23

Related issues

Related to TYPO3 Core - Bug #15215: Broken Rootline when a Editor view a Page that is not onlineClosedDmitry Dulepov2005-11-18

Actions
Related to TYPO3 Core - Bug #21706: Broken rootline when previewing versioned pages (not workpaces)Closed2009-11-26

Actions
#1

Updated by Administrator Admin almost 13 years ago

I can confirm this problem.

#2

Updated by Dmitry Dulepov almost 13 years ago

It appears that issue happens only and only for non-admin user

#4

Updated by Hercules Karvasonis over 12 years ago

I have the same problem with 4.2.

Non-Admin users cannot preview pages versions in the Live Workspace.

Did anybody find a fix about that?

#5

Updated by Mansoor Ahmad about 12 years ago

The same problem also have the Typo3 4.1.2!

#6

Updated by Yannick Pavard almost 12 years ago

Same problem with 4.2.3.

Page id = 1606, but preview id is 1607.

#7

Updated by Andreas Heling about 11 years ago

I made a patch for this issue. It is for version 4.2.9.
The problem was that $this->getRecord('pages',$id,'pid,t3ver_oid') in t3lib_userAuthGroup::isInWebMount() function returns null, becaus the $TCA is not set at this time.

#8

Updated by Thomas Rehhoff about 11 years ago

Along the same line: This is both for admins and non-admins btw.

1) Make a new version of a page (or a page and it's content - doesn't matter) - in live workspace.

2) switch to version preview (by right clicking on the page and in the click-menu choose "versioning" - NOT by using the Versioning-module!))

3) now you have Version overview and se the 2 versions of the page nicely aligned.

4) Click the preview icon of the unswaped page = you get the broken rootline error as mentioned in teh bugreport.

Btw, it's completely confusing, that there's a module "Versioning" and a clickmenu item called "Versioning" - but the y lead to completely different interfaces and functions of TYPO3.

#9

Updated by Tolleiv Nietsch over 9 years ago

  • Status changed from New to Closed
  • Target version deleted (0)

Issues have been fixed with the changes made in 4.5 - I assume this is outdated, feel free to reopen if that assumption was wrong

#10

Updated by Michael Stucki almost 7 years ago

  • Category set to Workspaces
#11

Updated by Michael Stucki almost 7 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

Also available in: Atom PDF