Feature #17108

Support secure database connections (e.g. MySQL over SSL)

Added by Oliver Hader almost 15 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2007-03-10
Due date:
% Done:

0%

Estimated time:
PHP Version:
4.3
Tags:
Complexity:
Sprint Focus:

Description

It would be great to have the feature to connect to a server somewhere in the internet by using a secure connection to the database. For the beginning this feature should be available for MySQL. In future mysqli and other DBMS could be integrated - but this is more related to DBAL.

http://dev.mysql.com/doc/refman/5.0/en/secure-connections.html
(issue imported from #M5187)


Related issues

Related to TYPO3 Core - Bug #91797: Typo3 Azure MySQLNew2020-07-13

Actions
#1

Updated by Martin Kutschker almost 15 years ago

I have started an extension that uses the mysqli API. It could be extended to support the SSL features.

#2

Updated by Oliver Hader almost 15 years ago

Great! Is this extension available in the TER? What do you think about merging/integrating the secure stuff to the Core or DBAL?

#3

Updated by Alexander Opitz over 8 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#4

Updated by Alexander Opitz over 8 years ago

  • Status changed from Needs Feedback to Closed

No feedback for over 90 days.

#5

Updated by Errol Mars almost 8 years ago

I can't find any information on this issue being resolved. This has become a very important feature to have now in light of services like Google Cloud SQL and Amazon RDS. For example the only secure way to connect to Google Cloud SQL is over SSL.

#6

Updated by Sascha Schmidt almost 2 years ago

Hi,

any news on that topic?

Greetings, Sascha

#7

Updated by Benni Mack almost 2 years ago

Sascha Schmidt wrote:

Hi,

any news on that topic?

Greetings, Sascha

Hey Sascha,

since TYPO3 v8, this can be configured by using the Doctrine DBAL configuration and put it into TYPO3_CONF_VARS[DB]... https://www.doctrine-project.org/projects/doctrine-dbal/en/2.10/reference/configuration.html - all configuration options depend on the RDBMS of course, but you'll see the different options for mysql and postgres etc. Does this help?

#8

Updated by Benni Mack about 2 months ago

Also available in: Atom PDF