Bug #17643

Sys_log table doesn't keep Switched User real name in the log

Added by Patrick Gaumond about 13 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Logging
Target version:
Start date:
2007-10-02
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

As an admin, if I use the Switch User feature in "Tools->User Admin", the actions looks like they're done by the corresponding switched user.

The username in the sy_log table should show that it was not the original user that did the actions.

Maybe just concatenating both username with "AS" is enough?

ex:
User patrickASbob logged in from 127.0.0.1

(issue imported from #M6434)


Related issues

Related to TYPO3 Core - Bug #71580: Switch-User feature uses wrong user id for logging Closed 2015-11-15

Associated revisions

Revision cc24b003 (diff)
Added by Zsolt Molnar almost 5 years ago

[BUGFIX] Log original user ID during backend user switch

If a user has currently switched to another user, use the original
user's ID for logging.

Resolves: #17643
Releases: master
Change-Id: I3c3197bf56e38f97f9552df2af376295ab639eae
Reviewed-on: https://review.typo3.org/44244
Reviewed-by: Stefan Neufeind <>
Reviewed-by: Ruud Silvrants <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Stefan Neufeind <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

Revision 4f623990 (diff)
Added by Oliver Hader over 4 years ago

[BUGFIX] Switch-User feature uses wrong user id for logging

Issue #17643 introduced logging for a simulated backend user
(switch-user) and thus logs by using the original admin user.

This is a regression in PageLayoutController::renderQuickEdit
since the used backend user id is different to the persisted
one. Besides that, all actions are performed with the permissions
of the simulated user - thus, logging with a different user seems
to wrong. The sys_log.log_data field (array) is used to transport
the information of the original (admin) user.

This change reverts the initial change of issue #17643 and adds
the initial intention of that issue as addition to the persisted
data in sys_log.log_data. All affected components are adjusted as
well to visualize that a user has been simulated (log view, record
history and lowlevel_cleaner syslog command).

Resolves: #71580
Releases: master, 7.6
Change-Id: If12df60563afd1f0746d43e62f824b20f139df8c
Reviewed-on: https://review.typo3.org/45490
Reviewed-by: Markus Klein <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision 90f44c54 (diff)
Added by Oliver Hader over 4 years ago

[BUGFIX] Switch-User feature uses wrong user id for logging

Issue #17643 introduced logging for a simulated backend user
(switch-user) and thus logs by using the original admin user.

This is a regression in PageLayoutController::renderQuickEdit
since the used backend user id is different to the persisted
one. Besides that, all actions are performed with the permissions
of the simulated user - thus, logging with a different user seems
to wrong. The sys_log.log_data field (array) is used to transport
the information of the original (admin) user.

This change reverts the initial change of issue #17643 and adds
the initial intention of that issue as addition to the persisted
data in sys_log.log_data. All affected components are adjusted as
well to visualize that a user has been simulated (log view, record
history and lowlevel_cleaner syslog command).

Resolves: #71580
Releases: master, 7.6
Change-Id: If12df60563afd1f0746d43e62f824b20f139df8c
Reviewed-on: https://review.typo3.org/45489
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Mathias Schreiber almost 6 years ago

  • Description updated (diff)
  • Category set to Logging
  • Status changed from New to Accepted
  • Target version changed from 0 to 7.0
  • PHP Version changed from 5.2 to 5.5

#2 Updated by Mathias Schreiber almost 6 years ago

  • Target version changed from 7.0 to 7.1 (Cleanup)

#3 Updated by Benni Mack over 5 years ago

  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)

#4 Updated by Susanne Moog about 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#5 Updated by Benni Mack about 5 years ago

  • Tracker changed from Feature to Bug
  • Target version changed from 7.5 to 7 LTS
  • TYPO3 Version set to 7
  • Is Regression set to No

#6 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44244

#7 Updated by Gerrit Code Review about 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44244

#8 Updated by Gerrit Code Review about 5 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44244

#9 Updated by Zsolt Molnar almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF