Bug #17904

showAccessRestrictedPages does not work with special menus

Added by Kurt almost 12 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2007-12-11
Due date:
% Done:

100%

TYPO3 Version:
4.1
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

A menu of type special * does not list acces restricted pages, even though showAccessRestrictedPages has been configured on the menu.
Below a TS snippet to repoduce.

This bug is similar to http://bugs.typo3.org/view.php?id=4754 . 4754 is more specific, but due to the same problem.

temp.countrydropdown = HMENU
temp.countrydropdown {
special = directory
special.value = 18

wrap = <div>|</div>
1 = JSMENU
1 {
showAccessRestrictedPages = 5864
target = _top
firstLabelGeneral = Choose Country
}
}
(issue imported from #M6922)

Associated revisions

Revision 29c3fad7 (diff)
Added by Claus Due almost 3 years ago

[BUGFIX] Make showAccessRestrictedPages work

This patch fixes a problem where setting showAccessRestrictedPages
setting in HMENU etc. did not result in the correct behavior according
to documentation at https://docs.typo3.org/typo3cms/TyposcriptReference/MenuObjects/CommonProperties/Index.html.

The patch changes the behavior caused by using `NONE` as
keyword in the setting.

Before: using the option renders `<a>Page title</a>` when page is inaccessible.

After: using the option renders `<a href="index.php?id=123">Page title</a>`
when page is not accessible.

Change-Id: I4364f7ec9f44e1e0b70654830efc236f20e6bf30
Resolves: #17904
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/50696
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Tested-by: TYPO3com <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

Revision 1441299e (diff)
Added by Claus Due almost 3 years ago

[BUGFIX] Make showAccessRestrictedPages work

This patch fixes a problem where setting showAccessRestrictedPages
setting in HMENU etc. did not result in the correct behavior according
to documentation at https://docs.typo3.org/typo3cms/TyposcriptReference/MenuObjects/CommonProperties/Index.html.

The patch changes the behavior caused by using `NONE` as
keyword in the setting.

Before: using the option renders `<a>Page title</a>` when page is inaccessible.

After: using the option renders `<a href="index.php?id=123">Page title</a>`
when page is not accessible.

Change-Id: I4364f7ec9f44e1e0b70654830efc236f20e6bf30
Resolves: #17904
Releases: master, 7.6
Reviewed-on: https://review.typo3.org/50775
Tested-by: TYPO3com <>
Reviewed-by: Jan Helke <>
Tested-by: Jan Helke <>

History

#1 Updated by Alexander Opitz over 6 years ago

  • Category deleted (Communication)
  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2 Updated by Thomas Allmer over 6 years ago

can confirm this with 6.0.5

10 = HMENU
10.special = list
10.special.value = 30
10.1 = TMENU
10.1.NO = 1
10.1.showAccessRestrictedPages = NONE

does not show any links...

config.typolinkLinkAccessRestrictedPages = NONE

is also set as without it "showAccessRestrictedPages = NONE" doesn't work at all even in "normal" menus

#3 Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to New

#4 Updated by Mathias Schreiber almost 5 years ago

  • Target version set to 7.2 (Frontend)
  • Is Regression set to No

#5 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.2 (Frontend) to 7.4 (Backend)

#6 Updated by Susanne Moog over 4 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#7 Updated by Benni Mack about 4 years ago

  • Target version changed from 7.5 to 7 LTS

#8 Updated by Mathias Schreiber about 4 years ago

  • Target version deleted (7 LTS)

#9 Updated by Riccardo De Contardi about 4 years ago

  • Category set to TypoScript

#10 Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#11 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#12 Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#13 Updated by Gerrit Code Review almost 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#14 Updated by Gerrit Code Review almost 3 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50775

#15 Updated by Gerrit Code Review almost 3 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#16 Updated by Anja Leichsenring almost 3 years ago

  • Sprint Focus set to On Location Sprint

#17 Updated by Gerrit Code Review almost 3 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#18 Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50775

#19 Updated by Gerrit Code Review almost 3 years ago

Patch set 3 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50775

#20 Updated by Gerrit Code Review almost 3 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50696

#21 Updated by Anonymous almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#22 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF