Bug #18738

rtehtmlarea: Argument 1 passed to t3lib_div::array_merge_recursive_overrule() must be an array, null given

Added by Ingmar Schlecht over 13 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2008-05-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The following error happens to me when I'm saving a tx_cal_event record that has uses the RTE HTMLArea:

Catchable fatal error: Argument 1 passed to t3lib_div::array_merge_recursive_overrule() must be an array, null given, called in /var/www/vhosts/test/TYPO3_4-2/typo3/sysext/rtehtmlarea/class.tx_rtehtmlareaapi.php on line 75 and defined in /var/www/vhosts/test/TYPO3_4-2/t3lib/class.t3lib_div.php on line 1764

The attached patch fixes the problem.
(issue imported from #M8314)


Files

rtehtmlarea_bugfix_8314.patch (530 Bytes) rtehtmlarea_bugfix_8314.patch Administrator Admin, 2008-06-26 00:20

Related issues

Related to TYPO3 Core - Bug #23651: htmlArea RTE: t3lib_div::array_merge_recursive_overrule() problem (#18738 follow-up)ClosedStanislas Rolland2010-09-30

Actions
#1

Updated by Stanislas Rolland about 13 years ago

This error occurs in FE? Something is wrong, because LOCAL_LANG is set in class.tx_rtehtmlarea_pi2.php by

$this->LOCAL_LANG = t3lib_div::readLLfile('EXT:' . $this->ID . '/locallang.xml', $this->language);

and t3lib_div::readLLfile always returns an array.

Otherwise the error occurs in the BE and rte api entered into the wrong branch.

#2

Updated by Administrator Admin about 13 years ago

I installed the attached patch and it works fine.
The problem is, that I can't create hyperlinks by clicking on the link icon. Sometimes the correct pop-up window for creating hyperlinks was opened, but sometimes one half of the popup window for inserting an image was opened.
I think the patch doesn't work correctly because before installing this patch, hyperlinks could be created without any problems.

#3

Updated by Dmitry Dulepov about 13 years ago

I have the same for tt_news when I have FE open in another tab in the same FF instance.

I reported this once in dev list but it was not reproducable. I thought it is unique problem for me.

#4

Updated by Dmitry Dulepov about 13 years ago

Btw, happens only when new item is created!

#5

Updated by Administrator Admin about 13 years ago

I have the problem also with tt_news.

#6

Updated by Stanislas Rolland about 13 years ago

Please test with attached patch:

rtehtmlarea_bugfix_8314.patch

in your environment(s).

#7

Updated by Stanislas Rolland about 13 years ago

Fixed in SVN TYPO3core branch TYPO3_4-2 revision 3848 (for inclusion in TYPO3 4.2.2) and trunk revision 3849.

#8

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF