Project

General

Profile

Actions

Bug #19102

closed

"Move page after" doesn't work correctly in workspace

Added by Andreas Ferber about 16 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2008-07-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When trying to move a page (a) after another page (b) that has already been moved in the workspace, the page (a) isn't moved to the correct position in the page tree. Instead, it is moved just after the position where page (b) has been before it was moved itself (ie. the position of (b) in the live workspace).

I'm attaching a patch that at least fixes the problem when using drag and drop in the page tree, I'm not really sure if I found all code parts where pages are moved.

(issue imported from #M8962)


Files


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #31663: Moving pages (and page content) in the Workspace does not workClosedStefan Neufeind2011-11-08

Actions
Actions #1

Updated by Administrator Admin over 15 years ago

The patch did not work wenn I tryed it with 4.2.4. I got a white screen instead of my website.

Actions #2

Updated by Stefan Neufeind over 12 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)

I guess this duplicates what 31663 attempts to fix (which is under review currently). If so, please test the patch over there

Actions #3

Updated by Oliver Hader over 12 years ago

  • Status changed from Needs Feedback to Resolved
  • Target version set to 4.5.8

Handled in issue #31663

Actions #4

Updated by Michael Stucki over 10 years ago

  • Category set to Workspaces
Actions #5

Updated by Michael Stucki over 10 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
Actions #6

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF