Bug #19919

"output handler 'ob_gzhandler' cannot be used after 'URL-Rewriter'" on backend login

Added by Carsten Pohle over 12 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2009-01-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On the backend login-screen, the message

Warning: ob_start() [ref.outcontrol]: output handler 'ob_gzhandler' cannot be used after 'URL-Rewriter' in /PATH_TO_TYPO3_INSTALL/typo3/init.php on line 389

appears.

Fix: Move the "compression" block befor the "BackEnd User authentication".

(issue imported from #M10273)


Files

bug_0010273.diff (1.04 KB) bug_0010273.diff Administrator Admin, 2009-01-26 16:02

Related issues

Has duplicate TYPO3 Core - Bug #21804: output handler 'ob_gzhandler' cannot be used after 'URL-Rewriter' in .... /typo3_src-4.3.0/typo3/init.php line 436ClosedChris topher2009-12-05

Actions
#1

Updated by Oliver Hader over 12 years ago

I can confirm this issue on a website running at Domainfactory...
Please tell whether you have phpMyAdmin installed and in what version.
Please also look into the headers sent back to the client and look for "Transfer-Encoding".
Thanks!

#2

Updated by Peter Kraume over 12 years ago

I can confirm this problem with Domainfactory and PMA 4.2.0 / PMA 4.3.0.
After uninstalling PMA the problem is gone.

#3

Updated by Steffen Gebert over 12 years ago

I can reproduce it on one site using 4.3-dev
not reproducable on another site running 4.2.6, but also with BE-compression enabled.
Both on dF-servers.

Could you find out anything more about this bug? Is PMA responsible for it or does this TYPO3 bug only caused by PMA?

#4

Updated by Tobias H. almost 12 years ago

I have the same error, with 4.3 now logged:

Core: Error handler (BE): PHP Warning: ob_start() [ref.outcontrol]: output handler 'ob_gzhandler' cannot be used after 'URL-Rewriter' in /../typo3_src-4.3.0/typo3/init.php line

I have this error only when the PMA is installed. Of course the newest version.

#5

Updated by Steffen Gebert over 11 years ago

This one is still valid, does anyone have an idea?

Tobias, are you also at domainfactory?

Don't know if it's a good idea to move the compression block around.

#6

Updated by Peter Kraume about 11 years ago

Any news on this issue?

#7

Updated by Oliver Hader about 11 years ago

Can somebody using Domainfactory please post the "zlib.*" part of the php.ini? I guess that compression is already enabled/defined there - thus, checking in TYPO3 if compression is already enabled should be enough.

#8

Updated by Steffen Gebert about 11 years ago

Settings are
zlib.output_compression Off Off
zlib.output_compression_level -1 -1
zlib.output_handler no value no value

#9

Updated by Steffen Gebert about 11 years ago

Searching the web shows we're not alone..

I found a PHP bug from back in 2003, when this error message was introduced: http://bugs.php.net/24315

PHP now (latest stable CVS) reports the correct error message
(ob_start(): output handler 'ob_gzhandler' cannot be used after
'URL-Rewriter') if you call ob_start('ob_gzhandler'); after
session_start hs been called and trans_sid is used.
The solution is to call ob_start('ob_gzhandler'); before
session_start().

#10

Updated by Steffen Gebert about 11 years ago

In EXT:phpmyadmin/res/phpMyAdmin-xxx/libraries/session.inc.php I see the following lines:

// but not all user allow cookies
@ini_set('session.use_only_cookies', false);
@ini_set('session.use_trans_sid', true);
@ini_set('url_rewriter.tags', 'a=href' ...)

As we 'can' cookies, I suggest to just remove these ini_set().
As adviced, session_start() is called afterwards, but I think TYPO3 itself already started a session.

Can sb. have a quick check on deactivating these lines, please?

#11

Updated by Steffen Gebert about 11 years ago

Doesn't work..

#12

Updated by Alexander Opitz almost 8 years ago

  • Status changed from Accepted to Needs Feedback
  • Target version deleted (0)
  • Is Regression set to No

Hi,

as this issue is very old. Does the problem still exists within newer versions of TYPO3 CMS (4.5 or 6.1)?

#13

Updated by Oliver Hader almost 8 years ago

In 6.x it's different due to the overworked bootstrap mechanism.
TYPO3 4.5 uses t3lib_utility_Http::redirect() in the backend user authentication which exits after a redirect.

Thus, in case of a redirect, the ob_gzhandler won't be triggered anymore.

#14

Updated by Oliver Hader almost 8 years ago

  • Status changed from Needs Feedback to Resolved
#15

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF