Bug #20194

Usability: Remove "Save and View" when creating records in sysfolders

Added by Dan Osipov about 10 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2009-03-16
Due date:
% Done:

100%

TYPO3 Version:
4.3
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When creating a record in a sysfolder, the "Save and VIew" button is still displayed, although it doesn't have any reasonable functionality.

See http://bugs.typo3.org/view.php?id=9663 for a related issue in DAM.
(issue imported from #M10706)

sysfolder_record.jpg View (118 KB) Administrator Admin, 2009-03-16 20:47

10706.diff View (925 Bytes) Administrator Admin, 2009-04-17 11:58

10706_v2.diff View (1001 Bytes) Administrator Admin, 2009-11-02 12:04

saveAndView_configuration_62.diff View (5.31 KB) Tim Lochmüller, 2013-07-11 10:29


Related issues

Related to TYPO3 Core - Feature #20265: Hide "Save and View"-button when editing a content-element Closed 2009-04-02
Related to TYPO3 Core - Feature #23085: Save and view only working with content and pages Closed 2010-07-03
Related to TYPO3 Core - Feature #49972: Configurable "Save and View"-Button for StorageFolder/Tables Closed 2013-07-12
Related to TYPO3 Core - Bug #55300: Inconsistent handling of Sys-folders New 2014-01-24
Related to TYPO3 Core - Bug #68376: Hide view-button according to configuration Closed 2015-07-20
Duplicated by TYPO3 Core - Feature #46279: Hide "Save and View" button as default when editing records in sysfolder Closed 2013-03-14

Associated revisions

Revision f6ad976a (diff)
Added by Frederic Gaus almost 4 years ago

[FEATURE] Hide "save and view" button where not useful

Per default the save&view button is not rendered anymore for the doktypes
254, 255 and 199. This behaviour can be changed by TSConfig.

Resolves: #49972
Resolves: #20194
Releases: master
Change-Id: I0eba112827521af0efb3c8049898e3e72d0d0838
Reviewed-on: http://review.typo3.org/22245
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

History

#1 Updated by Michael Klapper over 9 years ago

I attached a new version for that patch (10706_v2.diff). It provides the option to enable the "save & view" button for records if this is explicit desired.

This patch works as follow (example use tt_news):

- If nothing is set save&view button is hide.
- If "options.saveDocView.tt_news = 0", save & view button is still hidden.
- If "options.saveDocView.tt_news = 1" save & view button is available.

I woul like to see that version of patch in the core because i added some functionality to the ext linkhandler which enables a preview to records where an linkhandler configuration is available.

Thanks,
Mick

#2 Updated by Xavier Perseguers about 7 years ago

  • Assignee deleted (Steffen Kamper)
  • Target version deleted (0)

#3 Updated by Ernesto Baschny about 6 years ago

I like the approach of #23085, which is the most flexible one, but could get some more fine-tuning and enhancements:

  • Default Core behaviour should be "no links" generated for sys_folders and recycler folder.
  • Configurable PID and additional parameters on a "per table" basis configurable through PageTS (to make it easy for integrators).
  • PHP hook to be able to customize the generated link even further (like in #23085).
  • Hook should also be able to "withdraw" the link altogether (so that the icon is then not shown at all).

Something like that. :)

#4 Updated by Tim Lochmüller almost 6 years ago

Hey guys,

I check all (how many issues for just one function ;) ) tickets and create a feature-patch for the current 6.2 master.
Before I push the patch to the master, I hope I get a short feedback!

I respect Ernestos wishes:
- In the "default" no SaveAndView Button is renderd in the doctpyes: 254, 255 (configurable)
- Configuration of the target PID and also additionalParams for the previewLink vi TSConfig (the replacement of the ###UID### isn't realy smart. Any suggestions?)

common.table.tt_news.FePreviewPid = 101
common.table.tt_news.additionalParams = &test=###UID###

- central getHookObjects method for the EditCommandController incl. cache of the creation of the hook objects via internal static variable
- hook for the "processPreviewLink" to change the link via PHP
- hook for the "manipulateButtons" to remove/add buttons manually.

Any feedback and improvements?
If this is the right direction, I would add a new feature issue for the 6.2 master and push the changes to the Gerrit.

Regards,
Tim

#5 Updated by Tim Lochmüller almost 6 years ago

The feature is on the way.... http://forge.typo3.org/issues/49972

#6 Updated by Mathias Schreiber over 4 years ago

  • Target version set to 7.4 (Backend)
  • Is Regression set to No

#7 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Accepted to Under Review

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#8 Updated by Gerrit Code Review almost 4 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#9 Updated by Gerrit Code Review almost 4 years ago

Patch set 11 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#10 Updated by Gerrit Code Review almost 4 years ago

Patch set 12 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#11 Updated by Gerrit Code Review almost 4 years ago

Patch set 13 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#12 Updated by Gerrit Code Review almost 4 years ago

Patch set 14 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#13 Updated by Gerrit Code Review almost 4 years ago

Patch set 15 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#14 Updated by Gerrit Code Review almost 4 years ago

Patch set 16 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/22245

#15 Updated by Frederic Gaus almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#16 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF