Bug #20757

Session Timeout after BE Login IE8

Added by Michael Raberger over 10 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-07-15
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Sometimes after the login into the backend TYPO3 produces a session timeout when the page is redirecting to the main module page

this happens only with internet explorer version 8
A login with firefox fits perfect

(issue imported from #M11538)


Related issues

Related to TYPO3 Core - Bug #19883: timout after backend login in 4.2.4 Closed 2009-01-21
Related to TYPO3 Core - Bug #21511: Lots of HTML, JS and/or CSS errors force IE8 to switch to compatibility view Closed 2009-11-09
Related to TYPO3 Core - Bug #21065: Sporadic random Backend Logoffs Closed 2009-09-16

History

#1 Updated by Oliver Hader over 10 years ago

Did you experience any JavaScript errors on that behaviour?

#2 Updated by Michael Raberger over 10 years ago

No, there are no JavaScript errors

I'm still redirected to an error page after the login

#3 Updated by Søren Andersen over 10 years ago

I don't know if this is connected, but I have session timeout problems in IE8 (IE7 too). For me it works perfectly for a while, and then suddenly I'm logged out by a session timeout.

Sometimes it seems like it is happening when I open up tabs and visit other websites while being logged in to TYPO3.

In addition I have trouble being logged in on the frontend of my websites. One is running on 4.1.12 and the other is 4.2.8, I think it happened around 4.1.10 and 4.2.6. I didn't report it then because I hoped it would be fixed in newer versions, so I simply resorted to other browsers.

I'll try and be careful observing when the session timeout happens.

#4 Updated by Christian Kuhn over 10 years ago

Take a look to #19883 for further possible solutions.

#5 Updated by Lars Dyhr over 10 years ago

I have just encounter the same issue. I was using 4.2.6 and upgraded to 4.2.8, but that did not help. It turns out that I was running this site in IE8's new "Compatibility mode", and when I switched it back to NOT running in this mode it works perfectly again.
I have not looked into what this compatibility mode actually does, but apperently it interferes in a bad way.
Hope that this will bring us closer to sorting that issue (and that this is related to the bug that you have experienced).
NB: You can administer your compatibility mode if you open "Functions"=>"settings for compatibility views" (translated from a danish version).

#6 Updated by Lars Dyhr over 10 years ago

By the way as Oliver asked for JS errors I seem to get a few (none of them seem to be able to cause the bug I think). Anyway here they are:
This is printed from Microsofts IE debugger:

Et objekt er obligatorisk prototype.js, linje 3788 tegn 7
'x' er null eller ikke et objekt prototype.js, linje 3827 tegn 7
Et objekt er obligatorisk prototype.js, linje 3788 tegn 7
'Event.pointer(...).x' er null eller ikke et objekt prototype.js, linje 3796 tegn 33
Et objekt er obligatorisk prototype.js, linje 3788 tegn 7
'Event.pointer(...).y' er null eller ikke et objekt prototype.js, linje 3797 tegn 33

#7 Updated by Ralf Hettinger over 10 years ago

Problem occurs here as well with IE8 and "Compatibility View" activated (reproduced in 4.2.8 and early 4.3 version due to customer complaints; have neither checked with current trunk nor other IEs). Version of IE8: 8.0.6001.18702

To reproduce this error (haven't examined the reason yet):
- Activate "Compatibility View" in IE8
- Log in to backend
- Switch to frontend view and navigate there while being logged in to TYPO3.
- Try to use the backend => you're session is lost

#8 Updated by Søren Andersen over 10 years ago

I can lose the session in IE8 (TYPO3 4.1.12) without having compatibility view activated.

I open the browser, login to the backend, open a new tab, go to the front end and navigate a little, and bingo, session is lost.

So I don't think it's totally related to compatibility view.

#9 Updated by Ralf Hettinger over 10 years ago

I can't confirm losing BE session without Compatibility View.

Although and after playing around a bit, it seems (not to sure here) to be depending on the state of the Admin Panel and the shown fe editing options, so there might be situations different to the ones I'm testing with.

At least it should be possible to reproduce the error now which should allow to eventually track it down...

#10 Updated by Ralf Hettinger about 10 years ago

The following works for me (fixes the problem of losing session while navigating through the frontend):

TS setup:
config.headerComment (
-->
<meta http-equiv="X-UA-Compatible" content="IE=8" />
<!--
)

#11 Updated by Søren Andersen about 10 years ago

Ralf, I just tried out your solution, but with no luck.

I inserted the code in the frontend, confirmed that it showed up in "View source". While being on a front-end page, I opened up a new tab, logged in to the backend, switched to the front-end page, navigated to another page and then the session in the frontend was lost.

#12 Updated by Jo Hasenau about 10 years ago

Have a look at #21511 - could be the reason for lots of IE8 problems

#13 Updated by Chris topher over 9 years ago

I did not have this error after #21065 was committed.

Does this still happen to someone with 4.2.11 and 4.3.1 or newer?

#14 Updated by Steffen Gebert over 9 years ago

Michael, is this problem fixed?

#15 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF