Bug #19883

timout after backend login in 4.2.4

Added by Franz Holzinger about 11 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2009-01-21
Due date:
% Done:

0%

TYPO3 Version:
4.2
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Each time when I have logged into the backend, I am logged out immediately and get:

--------------------------------------------
Login-error or session timed-out

No user logged in! Sorry, I can't proceed then!

(You must have cookies enabled!)

If your session has just timed-out, you may
click here to re-login.

-----------
So I cannot login any more into the backend.
This happens in FF3 and Epiphany 2.24.0.1 .
It works fine in IE6.
It does not help to clear all caches.

(issue imported from #M10221)


Related issues

Related to TYPO3 Core - Bug #20757: Session Timeout after BE Login IE8 Closed 2009-07-15
Related to TYPO3 Core - Bug #19916: Session handling - cannot login to >1 TYPO3 installation under one domain Closed 2009-01-26
Related to TYPO3 Core - Bug #21511: Lots of HTML, JS and/or CSS errors force IE8 to switch to compatibility view Closed 2009-11-09

History

#1 Updated by Franz Holzinger about 11 years ago

The cookies for the backend must be cleared. Then it works.

#2 Updated by Christopher Hlubek over 10 years ago

Sorry, clearing just the cookies is not enough. This problem (or a similar problem) occurs even on new installations that are visited the first time! This is a very major problem for our clients and us.

The issue can be reproduced in the latest TYPO3 version (4.2.8). It works on the second login attempt though.

#3 Updated by Christian Kuhn over 10 years ago

Do you run several typo3 installations under one domain with subpathes?

eg.
foo.com/install1/typo3/
foo.com/install2/typo3/

Something like that?

#4 Updated by Michael Raberger over 10 years ago

Maybe this issue is related to this one: http://bugs.typo3.org/view.php?id=11538

#5 Updated by Christian Kuhn over 10 years ago

Other solutions:
- Server / Client Timezone work
- cookieDomain in localconf.php wrong

#6 Updated by Christopher Hlubek over 10 years ago

- Server / Client Timezone and time is perfectly in sync between Client and Server
- cookieDomain is not set

The problem is mostly solved by clicking on "re-login" and logging in again. Most of the time it is only the first login that fails.

#7 Updated by Andreas Wolf over 10 years ago

I also experience this problem from time to time. The only thing I noticed was that I was logged in on two installations under the same domain at the same time - that's what Christian also pointed out.

#8 Updated by Christian Kuhn over 10 years ago

Andreas, this should be solved with T3 4.1.11, 4.2.8 and trunk and was done with #19916 .

But the error will still occur, if you are logged in to one instance with a lower version (eg. 4.2.1) and then try to log in to another instance with 4.2.8. Solution: Update all your installations of this domain ...

#9 Updated by Lina Wolf over 10 years ago

I dont think that this bug weas resolved with the other bugfix. The logout in IE8 also happens when there is just one TYPO3 Installation under the domain.

#10 Updated by Jo Hasenau about 10 years ago

Check #21511

#11 Updated by Christian Kuhn almost 10 years ago

Resolved, no change required:

We had several thing that are all covered by related issues:
- The cookie problem solved the issue for the original author
- The subdomain thing is handled in some other isue
- The IE8 problem is already solved in core with this weird compatibility tag and covered by other issues

Let's close this issue for now and see if we still get new issues for current versions with more detailed bug analysis.

#12 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF